PHP vulnerability advisories

Every CVE phpwarden knows about across the PHP engine, Composer packages and WordPress plugins, themes and core — ranked by real-world exploitation. Feed 2026.10.28.3, updated 2026-10-28. Browse by package.

19,264CVEs
8,599Composer advisories
12,328WordPress advisories
35Actively exploited (KEV) →
CVEPackageTitleSeverityCVSSEPSS
CVE-2017-9841 KEVphpunit/phpunitCode Injection in PHPUnitcritical9.8100%
CVE-2026-109618 KEVPHP engineUpload-progress use-after-free and remote process-memory disclosurecritical9.2100%
CVE-2026-109619 KEVPHP engineFatal-error backtrace use-after-free and OPcache type confusioncritical9.2100%
CVE-2024-34102 KEVmagento/community-edition, magento/product-community-editionMagento Open Source affected by an Improper Restriction of XML External Entity Reference ('XXE') vulnerabilitycritical9.8100%
CVE-2018-7600 KEVdrupal/core, drupal/drupalA remote code execution vulnerability exists within multiple subsystems of Drupal 7.x and 8.x. This potentially allows acritical9.8100%
CVE-2024-4577 KEVPHP enginePHP-CGI argument injection to RCE on Windows via Best-Fit encodingcritical9.8100%
CVE-2021-3129 KEVfacade/ignitionUnauthenticated remote code execution via insecure file handling in debug modecritical9.8100%
CVE-2025-32432 KEVcraftcms/cmsCraft CMS Allows Remote Code Executioncritical10.0100%
CVE-2019-11043 KEVPHP enginePHP-FPM remote code execution via env_path_info buffer underflowcritical9.8100%
CVE-2016-10033 KEVphpmailer/phpmailerRemote code execution via crafted Sender in the isMail transportcritical9.8100%
CVE-2025-49113 KEVroundcube/roundcubemailRoundcube Webmail Vulnerable to Authenticated RCE via PHP Object Deserializationcritical9.9100%
CVE-2022-24086 KEVmagento/community-editionMagento improper input validation vulnerabilitycritical9.899%
CVE-2018-7602 KEVdrupal/core, drupal/drupalA remote code execution vulnerability exists within multiple subsystems of Drupal 7.x and 8.x. This potentially allows acritical9.899%
CVE-2021-21311 KEVvrana/adminerSSRF in adminerhigh7.298%
CVE-2020-11738 KEVduplicator (WordPress plugin)The Snap Creek Duplicator plugin before 1.3.28 for WordPress (and Duplicator Pro before 3.8.7.1) allows Directory Traversal via ../ in the fhigh7.598%
CVE-2024-56145 KEVcraftcms/cmsCraft CMS has potential RCE when PHP `register_argc_argv` config setting is enabledcritical9.897%
CVE-2020-25213 KEVwp-file-manager (WordPress plugin)Unauthenticated arbitrary file upload to RCE via the elFinder connectorcritical10.097%
CVE-2025-54068 KEVlivewire/livewireLivewire is vulnerable to remote command execution during component property update hydrationcritical9.896%
CVE-2025-54236 KEVmagento/community-edition, magento/project-community-editionMagento Community Edition Improper Input Validation vulnerabilitycritical9.195%
CVE-2019-6340 KEVdrupal/core, drupal/drupalSome field types do not properly sanitize data from non-form sources. This can lead to arbitrary PHP code execution in shigh8.192%
CVE-2021-32648 KEVoctober/systemAccount Takeover in Octobercmshigh8.290%
CVE-2026-9082 KEVdrupal/coreDrupal core includes a database abstraction API to ensure that queries executed against the database are sanitized to prcritical9.889%
CVE-2020-35489 KEVcontact-form-7 (WordPress plugin)Unrestricted file upload via unsanitised filenames (double extension)critical10.089%
CVE-2024-58136 KEVyiisoft/yii2yiisoft/yii2 Mishandles the Attaching of Behavior Defined by a `__class` Array Keycritical9.088%
CVE-2020-11023 KEVcomponents/jqueryPotential XSS vulnerability in jQuerymedium6.985%
CVE-2020-28949 KEVpear/archive_tarPotential file overwrite if archive filename starts with file://unknown0.085%
CVE-2018-15133 KEVlaravel/frameworkLaravel Framework RCE Vulnerabilityhigh8.177%
CVE-2019-9978 KEVsocial-warfare (WordPress plugin), social-warfare-pro (WordPress plugin)The social-warfare plugin before 3.5.3 for WordPress has stored XSS via the wp-admin/admin-post.php?swp_debug=load_options swp_url parametermedium6.173%
CVE-2020-36193 KEVpear/archive_tarDirectory Traversal in Archive_Tarhigh7.571%
CVE-2024-28000 KEVlitespeed-cache (WordPress plugin)Unauthenticated privilege escalation to administrator via weak hash in the crawlercritical9.868%
CVE-2020-13671 KEVdrupal/core, drupal/drupal*Update November 18: Documented longer list of dangerous file extensions* Drupal core does not properly sanitize certaihigh8.836%
CVE-2025-23209 KEVcraftcms/cmsCraft CMS has a potential RCE with a compromised security keyhigh8.022%
CVE-2026-63030 KEVWordPress coreWordPress 6.9.x before 6.9.5 and 7.0.x before 7.0.2 is affected by a REST API batch endpoint route confusion issue which, combined with the critical9.811%
CVE-2026-60137 KEVWordPress coreWordPress 6.8.x before 6.8.6, 6.9.x before 6.9.5, and 7.0.x before 7.0.2 does not properly sanitise the author__not_in parameter of WP_Querymedium5.95%
CVE-2025-35939 KEVcraftcms/cmsCraft CMS stores arbitrary content provided by unauthenticated users in session filesmedium5.31%
CVE-2020-11022athlon1600/youtube-downloader, components/jquery, maximebf/debugbarPotential XSS vulnerability in jQuerymedium6.999%
CVE-2022-39986billz/raspap-webguiRaspAP Command Injection vulnerabilitycritical9.899%
CVE-2022-24637open-web-analytics/open-web-analyticsImproper Privilege Management in Open Web Analyticscritical9.899%
CVE-2018-12613phpmyadmin/phpmyadminphpMyAdmin Improper Authenticationhigh8.898%
CVE-2023-6553backup-backup (WordPress plugin)The Backup Migration plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1.3.7 via the /includcritical9.898%
CVE-2022-21661WordPress coreWordPress is a free and open-source content management system written in PHP and paired with a MariaDB database. Due to improper sanitizatiohigh8.098%
CVE-2016-10045phpmailer/phpmailerRemote code execution in PHPMailercritical9.898%
CVE-2023-0315froxlor/froxlorFroxlor vulnerable to Command Injectionhigh8.898%
CVE-2019-9194studio-42/elfinderelFinder command injection vulnerability in the PHP connectorcritical9.897%
CVE-2020-11530chop-slider (WordPress plugin)A blind SQL injection vulnerability is present in Chop Slider 3, a WordPress plugin. The vulnerability is introduced in the id GET parametercritical9.895%
CVE-2020-24186wpdiscuz (WordPress plugin)A Remote Code Execution vulnerability exists in the gVectors wpDiscuz plugin 7.0 through 7.0.4 for WordPress, which allows unauthenticated ucritical10.095%
CVE-2020-14092payment-form-for-paypal-pro (WordPress plugin)The CodePeople Payment Form for PayPal Pro plugin before 1.1.65 for WordPress allows SQL Injection.critical9.895%
CVE-2022-3562librenms/librenmsCross-site Scripting in librenms/librenmsmedium5.494%
CVE-2023-41892craftcms/cmsCraft CMS Remote Code Execution vulnerabilitycritical10.094%
CVE-2024-8856wp-time-capsule (WordPress plugin)The Backup and Staging by WP Time Capsule plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation icritical9.894%
Page 1 of 386 · 19,264 advisories
Severity and CVSS come from the upstream advisory (OSV.dev, NVD, FriendsOfPHP); KEV marks CVEs on CISA's Known Exploited Vulnerabilities list; EPSS is FIRST's 30-day exploitation probability. Rows sort exploitation-first: KEV, then EPSS, then CVSS.