CVE-2017-5488: Multiple cross-site scripting (XSS) vulnerabilities in wp-admin/update-core.php in WordPress before 4.7.1 allow remote attackers to inject arbitrary web script or HTML via the (1) name or (2) version

medium Affects WordPress core. Feed 2026.10.29.1, updated 2026-10-28; published ; advisory modified .

Multiple cross-site scripting (XSS) vulnerabilities in wp-admin/update-core.php in WordPress before 4.7.1 allow remote attackers to inject arbitrary web script or HTML via the (1) name or (2) version

Package
WordPress core WordPress
Affected versions
<=4.7
Fixed in
no fix recorded
Severity
medium  CVSS 6.1
Exploitation
not on CISA KEV · EPSS 2% (77.8th percentile)
Published
2017-01-15
Source
nvd

References

CWE-79
NVD recordWordPress core advisories

Am I affected?

Find out in one command. phpwarden checks your WordPress install against this advisory and 20,000+ others, ranked by real-world exploitation (CISA KEV + EPSS). Free, offline, open data.

# one-time install
pip install phpwarden

# then
phpwarden wordpress /var/www/html

Or keep it checked automatically with the GitHub Action or a nightly cron; see WordPress docs.

Install docs   How findings are ranked

Related advisories