CVE-2020-11028: In affected versions of WordPress, some private posts, which were previously public, can result in unauthenticated disclosure under a specific set of conditions. This has been patched in version 5.4.1

medium Affects WordPress core. Feed 2026.10.29.1, updated 2026-10-28; published ; advisory modified .

In affected versions of WordPress, some private posts, which were previously public, can result in unauthenticated disclosure under a specific set of conditions. This has been patched in version 5.4.1

Package
WordPress core WordPress
Affected versions
<5.4.1
Fixed in
5.4.1
Severity
medium  CVSS 5.8
Exploitation
not on CISA KEV · EPSS 2% (83.4th percentile)
Published
2020-04-30
Source
nvd

References

CWE-284CWE-306
NVD recordWordPress core advisories

Am I affected?

Find out in one command. phpwarden checks your WordPress install against this advisory and 20,000+ others, ranked by real-world exploitation (CISA KEV + EPSS). Free, offline, open data.

# one-time install
pip install phpwarden

# then
phpwarden wordpress /var/www/html

Or keep it checked automatically with the GitHub Action or a nightly cron; see WordPress docs.

Install docs   How findings are ranked

Related advisories