CVE-2021-24348: The menu delete functionality of the Side Menu – add fixed side buttons WordPress plugin before 3.1.5, available to Administrator users takes the did GET parameter and uses it into an SQL statement wi

high Affects side-menu (WordPress plugin). Feed 2026.10.29.2, updated 2026-10-29; published ; advisory modified .

The menu delete functionality of the Side Menu – add fixed side buttons WordPress plugin before 3.1.5, available to Administrator users takes the did GET parameter and uses it into an SQL statement wi

Package
side-menu (WordPress plugin) WordPress
Affected versions
<3.1.5
Fixed in
3.1.5
Severity
high  CVSS 7.2
Exploitation
not on CISA KEV · EPSS 2% (75.2th percentile)
Published
2021-06-14
Source
nvd

References

CWE-89
NVD recordside-menu (WordPress plugin) advisories

Am I affected?

Find out in one command. phpwarden checks your WordPress install against this advisory and 20,000+ others, ranked by real-world exploitation (CISA KEV + EPSS). Free, offline, open data.

# PHP projects (recommended)
composer require --dev phpwarden/phpwarden
# then
vendor/bin/phpwarden wordpress /var/www/html

# or, without Composer
pipx install phpwarden   &&   phpwarden wordpress /var/www/html

Or keep it checked automatically with the GitHub Action or a nightly cron; see WordPress docs.

Install docs   How findings are ranked

Related advisories