CVE-2021-4374: The WordPress Automatic Plugin for WordPress is vulnerable to arbitrary options updates in versions up to, and including, 3.53.2. This is due to missing authorization and option validation in the proc

critical Affects wordpress-automatic-plugin (WordPress plugin). Feed 2026.10.29.1, updated 2026-10-28; published ; advisory modified .

The WordPress Automatic Plugin for WordPress is vulnerable to arbitrary options updates in versions up to, and including, 3.53.2. This is due to missing authorization and option validation in the proc

Package
wordpress-automatic-plugin (WordPress plugin) WordPress
Affected versions
<=3.53.2
Fixed in
no fix recorded
Severity
critical  CVSS 9.1
Exploitation
not on CISA KEV · EPSS 16% (97.0th percentile)
Published
2023-06-07
Source
nvd

References

CWE-862
NVD recordwordpress-automatic-plugin (WordPress plugin) advisories

Am I affected?

Find out in one command. phpwarden checks your WordPress install against this advisory and 20,000+ others, ranked by real-world exploitation (CISA KEV + EPSS). Free, offline, open data.

# one-time install
pip install phpwarden

# then
phpwarden wordpress /var/www/html

Or keep it checked automatically with the GitHub Action or a nightly cron; see WordPress docs.

Install docs   How findings are ranked

Related advisories