CVE-2022-1791: The One Click Plugin Updater WordPress plugin through 2.4.14 does not have CSRF check in place when updating its settings, which could allow attackers to make a logged in admin change them via a CSRF

high Affects one-click-plugin-updater (WordPress plugin). Feed 2026.10.29.4, updated 2026-10-29; published ; advisory modified .

The One Click Plugin Updater WordPress plugin through 2.4.14 does not have CSRF check in place when updating its settings, which could allow attackers to make a logged in admin change them via a CSRF

Package
one-click-plugin-updater (WordPress plugin) WordPress
Affected versions
<=2.4.14
Fixed in
no fix recorded
Severity
high  CVSS 8.1
Exploitation
not on CISA KEV · EPSS 1% (44.2th percentile)
Published
2022-06-13
Source
nvd

References

CWE-352
NVD recordone-click-plugin-updater (WordPress plugin) advisories

Am I affected?

Find out in one command. phpwarden checks your WordPress install against this advisory and 20,000+ others, ranked by real-world exploitation (CISA KEV + EPSS). Free, offline, open data.

# PHP projects (recommended)
composer require --dev phpwarden/phpwarden
# then
vendor/bin/phpwarden wordpress /var/www/html

# or, without Composer
pipx install phpwarden   &&   phpwarden wordpress /var/www/html

Or keep it checked automatically with the GitHub Action or a nightly cron; see WordPress docs.

Install docs   How findings are ranked

Related advisories