CVE-2022-2355: The Easy Username Updater WordPress plugin before 1.0.5 does not implement CSRF checks, which could allow attackers to make a logged in admin change any user's username includes the admin

medium Affects easy-username-updater (WordPress plugin). Feed 2026.10.29.1, updated 2026-10-28; published ; advisory modified .

The Easy Username Updater WordPress plugin before 1.0.5 does not implement CSRF checks, which could allow attackers to make a logged in admin change any user's username includes the admin

Package
easy-username-updater (WordPress plugin) WordPress
Affected versions
<1.0.5
Fixed in
1.0.5
Severity
medium  CVSS 6.5
Exploitation
not on CISA KEV · EPSS 0% (32.5th percentile)
Published
2022-08-08
Source
nvd

References

CWE-352
NVD recordeasy-username-updater (WordPress plugin) advisories

Am I affected?

Find out in one command. phpwarden checks your WordPress install against this advisory and 20,000+ others, ranked by real-world exploitation (CISA KEV + EPSS). Free, offline, open data.

# PHP projects (recommended)
composer require --dev phpwarden/phpwarden
# then
vendor/bin/phpwarden wordpress /var/www/html

# or, without Composer
pipx install phpwarden   &&   phpwarden wordpress /var/www/html

Or keep it checked automatically with the GitHub Action or a nightly cron; see WordPress docs.

Install docs   How findings are ranked

Related advisories