CVE-2024-7412: The No Update Nag plugin for WordPress is vulnerable to Full Path Disclosure in all versions up to, and including, 1.4.12. This is due to the plugin allowing direct access to the bootstrap.php file wh

medium Affects no-update-nag (WordPress plugin). Feed 2026.10.29.1, updated 2026-10-28; published ; advisory modified .

The No Update Nag plugin for WordPress is vulnerable to Full Path Disclosure in all versions up to, and including, 1.4.12. This is due to the plugin allowing direct access to the bootstrap.php file wh

Package
no-update-nag (WordPress plugin) WordPress
Affected versions
<=1.4.12
Fixed in
no fix recorded
Severity
medium  CVSS 5.3
Exploitation
not on CISA KEV · EPSS 0% (41.4th percentile)
Published
2024-08-12
Source
nvd

References

CWE-200
NVD recordno-update-nag (WordPress plugin) advisories

Am I affected?

Find out in one command. phpwarden checks your WordPress install against this advisory and 20,000+ others, ranked by real-world exploitation (CISA KEV + EPSS). Free, offline, open data.

# PHP projects (recommended)
composer require --dev phpwarden/phpwarden
# then
vendor/bin/phpwarden wordpress /var/www/html

# or, without Composer
pipx install phpwarden   &&   phpwarden wordpress /var/www/html

Or keep it checked automatically with the GitHub Action or a nightly cron; see WordPress docs.

Install docs   How findings are ranked

Related advisories