CVE-2025-5953: The WP Human Resource Management plugin for WordPress is vulnerable to Privilege Escalation due to missing authorization in the ajax_insert_employee() and update_empoyee() functions in versions 2.0.0

high Affects hrm (WordPress plugin). Feed 2026.10.29.1, updated 2026-10-28; published ; advisory modified .

The WP Human Resource Management plugin for WordPress is vulnerable to Privilege Escalation due to missing authorization in the ajax_insert_employee() and update_empoyee() functions in versions 2.0.0

Package
hrm (WordPress plugin) WordPress
Affected versions
>=2.0.0 and <=2.2.17
Fixed in
no fix recorded
Severity
high  CVSS 8.8
Exploitation
not on CISA KEV · EPSS 0% (38.3th percentile)
Published
2025-07-04
Source
nvd

References

CWE-862
NVD recordhrm (WordPress plugin) advisories

Am I affected?

Find out in one command. phpwarden checks your WordPress install against this advisory and 20,000+ others, ranked by real-world exploitation (CISA KEV + EPSS). Free, offline, open data.

# one-time install
pip install phpwarden

# then
phpwarden wordpress /var/www/html

Or keep it checked automatically with the GitHub Action or a nightly cron; see WordPress docs.

Install docs   How findings are ranked

Related advisories