GHSA-wqq8-mqj9-697f: PrestaShop autoupgrade module ZIP archives were vulnerable from CVE-2017-9841

high Affects prestashop/autoupgrade. Feed 2026.10.29.4, updated 2026-10-29; published ; advisory modified .

PrestaShop autoupgrade module ZIP archives were vulnerable from CVE-2017-9841

Package
prestashop/autoupgrade Composer
Affected versions
>=4.0.0 and <4.10.1
Fixed in
4.10.1
Severity
high
Exploitation
not on CISA KEV
Published
2020-01-08
Source
osv.dev

References

NVD recordprestashop/autoupgrade advisories

Am I affected?

Find out in one command. phpwarden checks your composer.lock against this advisory and 20,000+ others, ranked by real-world exploitation (CISA KEV + EPSS). Free, offline, open data.

# PHP projects (recommended)
composer require --dev phpwarden/phpwarden
# then
vendor/bin/phpwarden deps composer.lock

# or, without Composer
pipx install phpwarden   &&   phpwarden deps composer.lock

Or keep it checked automatically: GitHub Action · pre-commit hook · GitLab CI · Laravel artisan command

Install docs   How findings are ranked