PHP vulnerability advisories

Every CVE phpwarden knows about across the PHP engine, Composer packages and WordPress plugins, themes and core — ranked by real-world exploitation. Feed 2026.10.31.1, updated 2026-10-30. Browse by package.

19,312CVEs
8,647Composer advisories
12,328WordPress advisories
35Actively exploited (KEV) →
CVEPackageTitleSeverityCVSSEPSS
CVE-2022-2943ajax-load-more (WordPress plugin)The WordPress Infinite Scroll – Ajax Load More plugin for Wordpress is vulnerable to arbitrary file reading in versions up to, and includingmedium4.92%
CVE-2019-15895search-exclude (WordPress plugin)search-exclude.php in the "Search Exclude" plugin before 1.2.4 for WordPress allows unauthenticated options changes.high7.52%
CVE-2020-24149podcast-importer-secondline (WordPress plugin)Server-side request forgery (SSRF) in the Podcast Importer SecondLine (podcast-importer-secondline) plugin 1.1.4 for WordPress via the podcahigh7.52%
CVE-2022-2818cockpit-hq/cockpitCockpit Content Platform vulnerable to 2FA bypasshigh8.82%
CVE-2023-39526prestashop/prestashopPrestaShop SQL manager vulnerabilitycritical9.12%
CVE-2016-6623phpmyadmin/phpmyadminphpMyAdmin DoS Vulnerabilitymedium6.52%
CVE-2010-5296WordPress corewp-includes/capabilities.php in WordPress before 3.0.2, when a Multisite configuration is used, does not require the Super Admin role for thmedium4.92%
CVE-2016-2154moodle/moodleMoodle allows attackers to discover hidden course namesmedium4.32%
CVE-2016-2156moodle/moodleMoodle provides calendar-event data without considering whether an activity is hiddenmedium4.32%
CVE-2023-3342user-registration (WordPress plugin)The User Registration plugin for WordPress is vulnerable to arbitrary file uploads due to a hardcoded encryption key and missing file type vcritical9.92%
CVE-2022-3805jeg-elementor-kit (WordPress plugin)The Jeg Elementor Kit plugin for WordPress is vulnerable to authorization bypass in various functions used to update the plugin settings in high8.62%
CVE-2012-1207forkcms/forkcmsForkCMS Directory Traversal vulnerabilitymedium0.02%
CVE-2023-1381wp-meta-seo (WordPress plugin)The WP Meta SEO WordPress plugin before 4.5.5 does not validate image file paths before attempting to manipulate the image files, leading tohigh8.82%
CVE-2016-5702phpmyadmin/phpmyadminphpMyAdmin cookie-attribute injectionlow3.72%
CVE-2026-40261composer/composerComposer has a command injection via malicious perforce referencehigh8.82%
CVE-2017-18516bws-linkedin (WordPress plugin)The bws-linkedin plugin before 1.0.5 for WordPress has multiple XSS issues.medium6.12%
CVE-2017-18527pagination (WordPress plugin)The pagination plugin before 1.0.7 for WordPress has multiple XSS issues.medium6.12%
CVE-2023-2278wpdirectorykit (WordPress plugin)The WP Directory Kit plugin for WordPress is vulnerable to Local File Inclusion in versions up to, and including, 1.1.9 via the 'wdk_public_critical9.82%
CVE-2022-2219unyson (WordPress plugin)The Unyson WordPress plugin before 2.7.27 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflehigh7.22%
CVE-2025-2539file-away (WordPress plugin)The File Away plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the ajax() function in high7.52%
CVE-2020-24142video-downloader-for-tiktok (WordPress plugin)Server-side request forgery in the Video Downloader for TikTok (aka downloader-tiktok) plugin 1.3 for WordPress lets an attacker send craftecritical9.82%
CVE-2022-27862vikbooking (WordPress plugin)Arbitrary File Upload leading to RCE in E4J s.r.l. VikBooking Hotel Booking Engine & PMS plugin <= 1.5.3 on WordPress allows attackers to upcritical9.82%
CVE-2023-1273nd-shortcodes (WordPress plugin)The ND Shortcodes WordPress plugin before 7.0 does not validate some shortcode attributes before using them to generate paths passed to inclhigh8.82%
CVE-2020-10235froxlor/froxlorFroxlor arbitrary code execution via the database configuration optionshigh8.82%
CVE-2020-25830mantisbt/mantisbtMantisBT HTML Injection vulnerabilitymedium4.82%
CVE-2021-24319bello (WordPress plugin)The Bello - Directory & Listing WordPress theme before 1.6.0 did not properly sanitise its post_excerpt parameter before outputting it back medium5.42%
CVE-2015-5151slider-revolution (WordPress plugin)Cross-site scripting (XSS) vulnerability in the Slider Revolution (revslider) plugin 4.2.2 for WordPress allows remote attackers to inject amedium4.32%
CVE-2026-53932wnx/laravel-backup-restorelaravel-backup-restore has an OS Command Injection during database restorehigh8.02%
CVE-2016-10928onelogin-saml-sso (WordPress plugin)The onelogin-saml-sso plugin before 2.2.0 for WordPress has a hardcoded @@@nopass@@@ password for just-in-time provisioned users.high7.52%
CVE-2021-24695simple-download-monitor (WordPress plugin)The Simple Download Monitor WordPress plugin before 3.9.6 saves logs in a predictable location, and does not have any authentication or authhigh7.52%
CVE-2022-1008one-click-demo-import (WordPress plugin)The One Click Demo Import WordPress plugin before 3.1.0 does not validate the imported file, allowing high privilege users such as admin to high7.22%
CVE-2021-24252event-banner (WordPress plugin)The Event Banner WordPress plugin through 1.3 does not verify the uploaded image file, allowing admin accounts to upload arbitrary files, suhigh7.22%
CVE-2016-7570drupal/core, drupal/drupalDrupal Users without "Administer comments" can set comment visibility on nodes they can editmedium4.32%
CVE-2019-14366wp-slacksync (WordPress plugin)WP SlackSync plugin through 1.8.5 for WordPress leaks a Slack Access Token in source code. An attacker can obtain a lot of information abouthigh7.52%
CVE-2020-9392pricing-table-by-supsystic (WordPress plugin)An issue was discovered in the pricing-table-by-supsystic plugin before 1.8.2 for WordPress. Because there is no permission check on the Imphigh7.32%
CVE-2011-2718phpmyadmin/phpmyadminphpMyAdmin Directory Traversal Vulnerabilitymedium0.02%
CVE-2012-0796phpmailer/phpmailerPHPMailer vulnerable to email header injectionhigh0.02%
CVE-2020-7109elementor (WordPress plugin)The Elementor Page Builder plugin before 2.8.4 for WordPress does not sanitize data during creation of a new template.critical9.82%
CVE-2012-4422WordPress corewp-admin/plugins.php in WordPress before 3.4.2, when the multisite feature is enabled, does not check for network-administrator privileges blow3.52%
CVE-2020-35128mautic/coreMautic stored Cross-site Scripting (XSS)critical9.02%
CVE-2011-4289moodle/moodleMoodle does not recogniz configuration setting that makes e-mail addresses visible only to course membersmedium0.02%
CVE-2014-0124moodle/moodleMoodle allows attackers to obtain sensitive informationmedium0.02%
CVE-2014-7831moodle/moodleMoodle exposes hidden grades to studentsmedium0.02%
CVE-2014-7833moodle/moodleMoodle allows attackers to obtain sensitive informationmedium0.02%
CVE-2014-7834moodle/moodleMoodle does not verify group permissionsmedium0.02%
CVE-2015-0211moodle/moodleMoodle allows attackers to obtain sensitive informationmedium0.02%
CVE-2015-0215moodle/moodleMoodle allows attackers to obtain sensitive calendar-event informationmedium0.02%
CVE-2015-2266moodle/moodleMoodle allows attackers to obtain sensitive personal-contact and unread-message-count informationmedium0.02%
CVE-2015-3180moodle/moodleMoodle allows attackers to obtain sensitive course-structure informationmedium0.02%
CVE-2020-24146cm-download-manager (WordPress plugin)Directory traversal in the CM Download Manager (aka cm-download-manager) plugin 2.7.0 for WordPress allows authorized users to delete arbitrhigh8.12%
Page 62 of 387 · 19,312 advisories
Severity and CVSS come from the upstream advisory (OSV.dev, NVD, FriendsOfPHP); KEV marks CVEs on CISA's Known Exploited Vulnerabilities list; EPSS is FIRST's 30-day exploitation probability. Rows sort exploitation-first: KEV, then EPSS, then CVSS.