PHP vulnerability advisories

Every CVE phpwarden knows about across the PHP engine, Composer packages and WordPress plugins, themes and core — ranked by real-world exploitation. Feed 2026.10.31.2, updated 2026-10-31. Browse by package.

19,312CVEs
8,647Composer advisories
12,328WordPress advisories
35Actively exploited (KEV) →
CVEPackageTitleSeverityCVSSEPSS
CVE-2021-31777t3/dceSQL Injection in t3/dcehigh7.61%
CVE-2015-4070wow-moodboard-lite (WordPress plugin)Open redirect vulnerability in the proxyimages function in wowproxy.php in the Wow Moodboard Lite plugin 1.1.1.1 for WordPress allows remotemedium6.11%
CVE-2023-29384jobwp (WordPress plugin)Unrestricted Upload of File with Dangerous Type vulnerability in HM Plugin WordPress Job Board and Recruitment Plugin – JobWP.This issue affcritical10.01%
CVE-2023-24776funadmin/funadminRemote code execution in Funadmincritical9.81%
CVE-2021-24765perfect-survey (WordPress plugin)The Perfect Survey WordPress plugin through 1.5.2 does not validate and escape the X-Forwarded-For header value before outputting it in the medium6.11%
CVE-2019-9942twig/twigTwig Sandbox Information Disclosurelow3.71%
CVE-2021-36027magento/community-edition, magento/project-community-editionMagento stored cross-site scripting vulnerabilitymedium0.01%
CVE-2017-18590timesheet (WordPress plugin)The timesheet plugin before 0.1.5 for WordPress has multiple XSS issues.medium6.11%
CVE-2017-1000490mautic/coreMautic users able to download any files from server using filemanagermedium6.51%
CVE-2015-5264moodle/moodleMoodle allows attackers to enter additional answer attemptsmedium5.41%
CVE-2015-8379cakephp/cakephpCakePHP might allow remote attackers to bypass CSRF protection mechanism via the _method parameterhigh8.81%
CVE-2021-25030events-made-easy (WordPress plugin)The Events Made Easy WordPress plugin before 2.2.36 does not sanitise and escape the search_text parameter before using it in a SQL statemenhigh8.81%
CVE-2022-3869froxlor/froxlorFroxlor vulnerable to code injectionmedium6.11%
CVE-2021-24457portfolio-responsive-gallery (WordPress plugin)The get_portfolios() and get_portfolio_attributes() functions in the class-portfolio-responsive-gallery-list-table.php and class-portfolio-rhigh8.81%
CVE-2021-41270symfony/serializer, symfony/symfonyCSV Injection in symfony/serializermedium6.51%
CVE-2017-18493custom-admin-page (WordPress plugin)The custom-admin-page plugin before 0.1.2 for WordPress has multiple XSS issues.medium6.11%
CVE-2017-18494custom-search-plugin (WordPress plugin)The custom-search-plugin plugin before 1.36 for WordPress has multiple XSS issues.medium6.11%
CVE-2017-18496htaccess (WordPress plugin)The htaccess plugin before 1.7.6 for WordPress has multiple XSS issues.medium6.11%
CVE-2011-4279moodle/moodleMoodle does not use the forceloginforprofiles setting for course-profiles access controlmedium0.01%
CVE-2014-3546moodle/moodleMoodle allows attackers to obtain username and course informationmedium0.01%
CVE-2019-16318pimcore/pimcorePimcore Unrestricted Upload of File with Dangerous Typehigh8.81%
CVE-2022-28290wordpress-country-selector (WordPress plugin)Reflective Cross-Site Scripting vulnerability in WordPress Country Selector Plugin Version 1.6.5. The XSS payload executes whenever the usermedium6.11%
CVE-2010-5294WordPress coreMultiple cross-site scripting (XSS) vulnerabilities in the request_filesystem_credentials function in wp-admin/includes/file.php in WordPresmedium4.31%
CVE-2022-0721microweber/microweberInsertion of Sensitive Information Into Debugging Code in Microweberhigh8.81%
CVE-2021-28556magento/community-edition, magento/project-community-editionMagento DOM-based Cross-Site Scripting vulnerability on mage-messages cookiesmedium6.91%
CVE-2021-24934visual-css-style-editor (WordPress plugin)The Visual CSS Style Editor WordPress plugin before 7.5.4 does not sanitise and escape the wyp_page_type parameter before outputting it backmedium6.11%
CVE-2019-17235igniteup (WordPress plugin)includes/class-coming-soon-creator.php in the igniteup plugin through 3.4 for WordPress allows information disclosure.medium5.31%
CVE-2022-0385crazy-bone (WordPress plugin)The Crazy Bone WordPress plugin through 0.6.0 does not sanitise and escape the username submitted via the login from when displaying them bamedium6.11%
CVE-2021-44618nystudio107/craft-seomaticServer-side Template Injection in nystudio107/craft-seomaticcritical9.81%
CVE-2025-24406magento/community-edition, magento/project-community-editionAdobe Commerce Path Traversalhigh7.51%
CVE-2019-16521broken-link-checker (WordPress plugin)The broken-link-checker plugin through 1.11.8 for WordPress (aka Broken Link Checker) is susceptible to Reflected XSS due to improper encodimedium6.11%
CVE-2013-4744oliverklee/phpunitPHPUnit extension for TYPO3 vulnerable to Cross-site Scriptinglow0.01%
CVE-2019-11018zoujingli/thinkadminThinkAdmin Administrator cookies still working after password changecritical9.81%
CVE-2024-28117getgrav/gravServer Side Template Injection (SSTI)high8.81%
CVE-2021-20185moodle/moodleMoodle Client side denial of service via personal messagemedium5.31%
CVE-2022-2317simple-membership (WordPress plugin)The Simple Membership WordPress plugin before 4.1.3 allows user to change their membership at the registration stage due to insufficient checritical9.81%
CVE-2019-16403bagisto/bagistoAuthorization Bypass Through User-Controlled Key in Bagistohigh8.81%
CVE-2022-40043centreon/centreonCentreon SQL Injection vulnerability via esc_name parameterhigh8.81%
CVE-2019-18981pimcore/pimcorePimcore Access Control Issuescritical9.81%
CVE-2022-24752sylius/grid-bundleDQL injection through sorting parameters blockedcritical9.81%
CVE-2019-12463librenms/librenmsImproper Encoding or Escaping of Output and Injection in LibreNMShigh8.81%
CVE-2018-20980ninja-forms (WordPress plugin)The ninja-forms plugin before 3.2.15 for WordPress has parameter tampering.high7.51%
CVE-2016-10952quotes-collection (WordPress plugin)The quotes-collection plugin before 2.0.6 for WordPress has XSS via the wp-admin/admin.php?page=quotes-collection page parameter.medium6.11%
CVE-2023-6220piotnetforms (WordPress plugin)The Piotnet Forms plugin for WordPress is vulnerable to arbitrary file uploads due to insufficient file type validation in the 'piotnetformshigh8.11%
CVE-2021-31567download-monitor (WordPress plugin)Authenticated (admin+) Arbitrary File Download vulnerability discovered in Download Monitor WordPress plugin (versions <= 4.4.6). The pluginmedium6.81%
CVE-2019-10864wp-statistics (WordPress plugin)The WP Statistics plugin through 12.6.2 for WordPress has XSS, allowing a remote attacker to inject arbitrary web script or HTML via the Refmedium6.11%
CVE-2021-41745showdoc/showdocShowdoc File Upload Vulnerabilitycritical9.81%
CVE-2024-9634give (WordPress plugin)The GiveWP – Donation Plugin and Fundraising Platform plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and critical9.81%
CVE-2017-18564sender (WordPress plugin)The sender plugin before 1.2.1 for WordPress has multiple XSS issues.medium6.11%
CVE-2017-18565updater (WordPress plugin)The updater plugin before 1.35 for WordPress has multiple XSS issues.medium6.11%
Page 78 of 387 · 19,312 advisories
Severity and CVSS come from the upstream advisory (OSV.dev, NVD, FriendsOfPHP); KEV marks CVEs on CISA's Known Exploited Vulnerabilities list; EPSS is FIRST's 30-day exploitation probability. Rows sort exploitation-first: KEV, then EPSS, then CVSS.