PHP vulnerability advisories

Every CVE phpwarden knows about across the PHP engine, Composer packages and WordPress plugins, themes and core — ranked by real-world exploitation. Feed 2026.10.29.4, updated 2026-10-29. Browse by package.

19,303CVEs
8,638Composer advisories
12,328WordPress advisories
35Actively exploited (KEV) →
CVEPackageTitleSeverityCVSSEPSS
CVE-2013-2011w3-super-cache (WordPress plugin)WordPress W3 Super Cache Plugin before 1.3.2 contains a PHP code-execution vulnerability which could allow remote attackers to inject arbitrhigh8.85%
CVE-2022-0210random-banner (WordPress plugin)The Random Banner WordPress plugin is vulnerable to Stored Cross-Site Scripting due to insufficient escaping via the category parameter founmedium4.84%
CVE-2020-13625phpmailer/phpmailerInsufficient output escaping of attachment names in PHPMailerhigh7.54%
CVE-2019-11325symfony/symfony, symfony/var-exporterImproper Input Validation in Symfonycritical9.83%
CVE-2022-0220wordpress-gdpr\&ccpa (WordPress plugin)The check_privacy_settings AJAX action of the WordPress GDPR WordPress plugin before 1.9.27, available to both unauthenticated and authenticmedium6.12%
CVE-2019-12463librenms/librenmsImproper Encoding or Escaping of Output and Injection in LibreNMShigh8.81%
CVE-2021-39170pimcore/pimcoreImproper Encoding or Escaping of Output in Asset Metadata Componenthigh8.01%
CVE-2020-10960mediawiki/coreMediaWiki makeCollapsible allows applying event handler to any CSS selectormedium5.31%
CVE-2020-36173ninja-forms (WordPress plugin)The Ninja Forms plugin before 3.4.28 for WordPress lacks escaping for submissions-table fields.medium5.31%
CVE-2025-46347yeswiki/yeswikiYesWiki Remote Code Execution via Arbitrary PHP File Write and Executionhigh0.01%
CVE-2023-3668froxlor/froxlorFroxlor vulnerable to Improper Encoding or Escaping of Outputcritical9.11%
CVE-2021-40694moodle/moodleMoodle Improper Encoding or Escaping of Outputmedium4.91%
CVE-2019-19714contao/contao, contao/core-bundleInsert tag injection in the Contao login modulemedium5.31%
CVE-2022-22734simple-quotation (WordPress plugin)The Simple Quotation WordPress plugin through 1.3.2 does not have CSRF check when creating or editing a quote and does not sanitise and escamedium6.11%
CVE-2026-54182backpack/crudLaravel Backpack CRUD: OS command injection in Stats::makeCurlRequest via attacker-controlled Host header (pre-auth)high8.11%
CVE-2022-2099woocommerce (WordPress plugin), woocommerce/woocommerceThe WooCommerce WordPress plugin before 6.6.0 is vulnerable to stored HTML injection due to lack of escaping and sanitizing in the payment gmedium4.81%
CVE-2022-2241featured-image-from-url (WordPress plugin)The Featured Image from URL (FIFU) WordPress plugin before 4.0.1 does not have CSRF check in place when updating its settings, which could amedium6.11%
CVE-2022-0450menu-image\,-icons-made-easy (WordPress plugin)The Menu Image, Icons made easy WordPress plugin before 3.0.6 does not have authorisation and CSRF checks when saving menu settings, and doemedium5.41%
CVE-2024-34355typo3/cms-coreTYPO3 vulnerable to an HTML Injection in the History Modulelow3.51%
CVE-2022-0421five-star-restaurant-reservations (WordPress plugin)The Five Star Restaurant Reservations WordPress plugin before 2.4.12 does not have authorisation when changing whether a payment was successmedium6.11%
CVE-2023-3552nilsteampassnet/teampassTeamPass vulnerable to Improper Encoding or Escaping of Outputhigh7.61%
CVE-2026-55891privatebin/privatebinPrivateBin has reflected JSON injection in backend responses via unescaped REQUEST_URIlow0.01%
CVE-2023-3190nilsteampassnet/teampassTeampass Cross-site Scripting vulnerabilitymedium4.61%
CVE-2023-39527prestashop/prestashopPrestaShop XSS injection through Validate::isCleanHTML methodhigh8.31%
CVE-2026-54133mtdowling/jmespath.phpjmespath.php has CompilerRuntime code injection via unescaped function namescritical9.80%
CVE-2023-6005eventon (WordPress plugin)The EventON WordPress plugin before 4.5.5, EventON WordPress plugin before 2.2.7 does not sanitize and escape some of its settings, which comedium4.80%
CVE-2024-47528librenms/librenmsLibreNMS vulnerable to Stored Cross-site Scripting via File Uploadmedium4.80%
CVE-2024-0233eventon (WordPress plugin)The EventON WordPress plugin before 4.5.5, EventON WordPress plugin before 2.2.7 do not properly sanitise and escape a parameter before outpmedium6.10%
CVE-2024-39682cooked (WordPress plugin)Cooked is a recipe plugin for WordPress. The Cooked plugin for WordPress is vulnerable to HTML Injection in versions up to, and including, 1medium6.40%
CVE-2026-52772yeswiki/yeswikiYesWiki has stored XSS in Bazar form-field templates via unescaped field.label / field.hint (|raw('html'))medium5.50%
CVE-2026-46637twig/cssinliner-extra, twig/markdown-extraTwig: HTML-output filters in twig/* extras incorrectly declared `is_safe => ['all']`low0.00%
CVE-2026-46628twig/twigTwig: The `spaceless` filter implicitly marks its output as safelow0.00%
CVE-2026-107845contao/comments-bundleContao: Cross-site scripting in the comments bundlecritical9.30%
CVE-2026-27016librenms/librenmsLibreNMS has a Stored XSS in Custom OID - unit parameter missing strip_tags()medium5.40%
CVE-2026-46367phpmyfaq/phpmyfaq, thorsten/phpmyfaqphpMyFAQ has stored XSS via Utils::parseUrl() in comment renderinghigh7.60%
CVE-2026-33628invoiceninja/invoiceninjaInvoice Ninja Denylist Bypass may Lead to Stored XSS via Invoice Line Itemsmedium5.40%
CVE-2026-31859craftcms/cmsCraftCMS vulnerable to reflective XSS via incomplete return URL sanitizationmedium0.00%
GHSA-crmm-hgp2-wgrplaravel/frameworkLaravel Framework: Temporary Signed URL Path Confusionmedium4.2–
CVE-2026-45710facturascripts/facturascriptsFacturaScripts: Stored XSS in WidgetVariante and WidgetSubcuenta modal lists via HTML-attribute decoding of `Tools::noHtml`-escaped quotes ilow3.5–
GHSA-6jq6-x4cx-qvcmgrumpydictator/firefly-iiiFirefly II has Stored XSS in Audit Log Entry view via piggy bank name (ale.twig)medium0.0–
Page 1 of 1 · 40 advisories
Severity and CVSS come from the upstream advisory (OSV.dev, NVD, FriendsOfPHP); KEV marks CVEs on CISA's Known Exploited Vulnerabilities list; EPSS is FIRST's 30-day exploitation probability. Rows sort exploitation-first: KEV, then EPSS, then CVSS.