PHP vulnerability advisories

Every CVE phpwarden knows about across the PHP engine, Composer packages and WordPress plugins, themes and core — ranked by real-world exploitation. Feed 2026.10.29.4, updated 2026-10-29. Browse by package.

19,303CVEs
8,638Composer advisories
12,328WordPress advisories
35Actively exploited (KEV) →
CVEPackageTitleSeverityCVSSEPSS
CVE-2018-7600 KEVdrupal/core, drupal/drupalA remote code execution vulnerability exists within multiple subsystems of Drupal 7.x and 8.x. This potentially allows acritical9.8100%
CVE-2022-24086 KEVmagento/community-editionMagento improper input validation vulnerabilitycritical9.899%
CVE-2025-54236 KEVmagento/community-edition, magento/project-community-editionMagento Community Edition Improper Input Validation vulnerabilitycritical9.195%
CVE-2017-5487WordPress corewp-includes/rest-api/endpoints/class-wp-rest-users-controller.php in the REST API implementation in WordPress 4.7 before 4.7.1 does not propmedium5.387%
CVE-2018-7251anchorcms/anchor-cmsAnchor CMS Logs Credentialscritical9.872%
CVE-2021-39327bulletproof-security (WordPress plugin)The BulletProof Security WordPress plugin is vulnerable to sensitive information disclosure due to a file path disclosure in the publicly acmedium5.372%
CVE-2014-5460slideshow-gallery (WordPress plugin)Unrestricted file upload vulnerability in the Tribulant Slideshow Gallery plugin before 1.4.7 for WordPress allows remote authenticated usermedium6.571%
CVE-2024-50340symfony/runtime, symfony/symfonySymfony allows changing the environment through a queryhigh7.362%
CVE-2016-1209ninja-forms (WordPress plugin)The Ninja Forms plugin before 2.9.42.1 for WordPress allows remote attackers to conduct PHP object injection attacks via crafted serialized critical9.862%
CVE-2010-4335cakephp/cakephpCakePHP allows remote attackers to modify internal Cake cache and execute arbitrary codehigh0.055%
CVE-2022-35650moodle/moodleMoodle Arbitrary file read when importing lesson questionshigh7.554%
CVE-2020-13756sabberworm/php-css-parserSabberworm PHP CSS Parser Code injection vulnerability in allSelectors()critical9.850%
CVE-2014-9013wpmarketplace (WordPress plugin)The ajaxinit function in wpmarketplace/libs/cart.php in the WP Marketplace plugin 2.4.0 for WordPress allows remote authenticated users to chigh8.846%
CVE-2009-0815typo3/cmsTYPO3 leaks a hash secret in an error messagemedium0.042%
CVE-2014-2383dompdf/dompdfDOMPDF Arbitrary File Readmedium0.039%
CVE-2018-14009codiad/codiadCodiad remote code execution vulnerabilitycritical9.838%
CVE-2019-17671WordPress coreIn WordPress before 5.2.4, unauthenticated viewing of certain content is possible because the static query property is mishandled.medium5.337%
CVE-2019-6339drupal/core, drupal/drupalA remote code execution vulnerability exists in PHP's built-in phar stream wrapper when performing file operations on ancritical9.836%
CVE-2023-4197dolibarr/dolibarrDolibarr Improper Input Validation vulnerabilityhigh7.536%
CVE-2021-38314gutenberg-template-library-\&-redux-framework (WordPress plugin)The Gutenberg Template Library & Redux Framework plugin <= 4.2.11 for WordPress registered several AJAX actions available to unauthenticatedmedium5.329%
CVE-2016-3109shopware/shopwareShopware RCE Vulnerabilitycritical9.828%
CVE-2007-1277WordPress coreWordPress 2.1.1, as downloaded from some official distribution sites during February and March 2007, contains an externally introduced backdhigh7.528%
CVE-2019-16405centreon/centreonImproper Input Validation in Centreon Webhigh7.227%
CVE-2023-2916iwp-client (WordPress plugin)The InfiniteWP Client plugin for WordPress is vulnerable to Sensitive Information Exposure in versions up to, and including, 1.11.1 via the high7.524%
CVE-2018-19246athlon1600/php-proxyLFI in PHP-Proxy 5.1.0high7.522%
CVE-2021-4428autosuggest (WordPress plugin)A vulnerability has been found in what3words Autosuggest Plugin up to 4.0.0 on WordPress and classified as problematic. Affected by this vullow2.716%
CVE-2013-0291nextgen-gallery (WordPress plugin)NextGEN Gallery Plugin for WordPress 1.9.10 and 1.9.11 has a Path Disclosure Vulnerabilityhigh7.516%
CVE-2023-33568dolibarr/dolibarrDolibarr vulnerable to unauthenticated database accesshigh7.515%
CVE-2013-7102optimizepress (WordPress theme)Multiple unrestricted file upload vulnerabilities in (1) media-upload.php, (2) media-upload-lncthumb.php, and (3) media-upload-sq_button.phpmedium6.815%
CVE-2020-13405microweber/microweberMicroweber Discloses Sensitive Informationhigh7.514%
CVE-2020-13700acf-to-rest-api (WordPress plugin), airesvsg/acf-to-rest-apiAn issue was discovered in the acf-to-rest-api plugin through 3.1.0 for WordPress. It allows an insecure direct object reference via permalihigh7.513%
CVE-2015-2826simple-ads-manager (WordPress plugin)WordPress Simple Ads Manager plugin 2.5.94 and 2.5.96 allows remote attackers to obtain sensitive information.medium5.313%
CVE-2011-4107phpmyadmin/phpmyadminphpMyAdmin vulnerable to XML external entity (XXE) injection attackmedium6.513%
CVE-2017-18580shortcodes-ultimate (WordPress plugin)The shortcodes-ultimate plugin before 5.0.1 for WordPress has remote code execution via a filter in a meta, post, or user shortcode.critical9.812%
CVE-2008-5695WordPress corewp-admin/options.php in WordPress MU before 1.3.2, and WordPress 2.3.2 and earlier, does not properly validate requests to update an option,high8.512%
CVE-2016-10956mail-masta (WordPress plugin)The mail-masta plugin 1.0 for WordPress has local file inclusion in count_of_send.php and csvexport.php.high7.511%
CVE-2022-0281microweber/microweberExposure of Sensitive Information to an Unauthorized Actor in microweberhigh7.510%
CVE-2015-6830phpmyadmin/phpmyadminphpMyAdmin ReCaptcha bypassmedium0.010%
CVE-2018-20555social-network-tabs (WordPress plugin)The Design Chemical Social Network Tabs plugin 1.7.1 for WordPress allows remote attackers to discover Twitter access_token, access_token_secritical9.810%
CVE-2015-6668job-manager (WordPress plugin)The Job Manager plugin before 0.7.25 allows remote attackers to read arbitrary CV files via a brute force attack to the WordPress upload dirhigh7.510%
CVE-2015-1000012mypixs (WordPress plugin)Local File Inclusion Vulnerability in mypixs v0.3 wordpress pluginhigh7.59%
CVE-2024-45440drupal/core, drupal/core-recommended, drupal/drupalDrupal Full Path Disclosuremedium5.39%
CVE-2011-4898WordPress corewp-admin/setup-config.php in the installation component in WordPress 3.3.1 and earlier generates different error messages for requests lackimedium5.09%
CVE-2016-10960wsecure (WordPress plugin)The wsecure plugin before 2.4 for WordPress has remote code execution via shell metacharacters in the wsecure-config.php publish parameter.high8.89%
CVE-2022-35649moodle/moodleMoodle PostScript Code Injectioncritical9.89%
CVE-2018-1000773WordPress coreWordPress version 4.9.8 and earlier contains a CWE-20 Input Validation vulnerability in thumbnail processing that can result in remote code high8.88%
CVE-2013-4339WordPress coreWordPress before 3.6.1 does not properly validate URLs before use in an HTTP redirect, which allows remote attackers to bypass intended redihigh7.58%
CVE-2018-20985wp-payeezy-pay (WordPress plugin)The wp-payeezy-pay plugin before 2.98 for WordPress has local file inclusion in pay.php, donate.php, donate-rec, and pay-rec.critical9.88%
CVE-2015-6497magento/coreMagento arbitrary PHP code execution via the productData parameterhigh8.87%
CVE-2020-9043wp-central (WordPress plugin)The wpCentral plugin before 1.5.1 for WordPress allows disclosure of the connection key.high8.87%
Page 1 of 20 · 991 advisories
Severity and CVSS come from the upstream advisory (OSV.dev, NVD, FriendsOfPHP); KEV marks CVEs on CISA's Known Exploited Vulnerabilities list; EPSS is FIRST's 30-day exploitation probability. Rows sort exploitation-first: KEV, then EPSS, then CVSS.