Is devcode-it/openstamanager vulnerable?

Composer devcode-it/openstamanager has 18 known advisories in the phpwarden feed. Feed 2026.10.29.1, updated 2026-10-28.

18advisories
2critical
0on CISA KEV
11no fix recorded
CVETitleSeverityCVSSAffectedFixed in
CVE-2025-69212OpenSTAManager has an OS Command Injection in P7M File Processingcritical0.0<=2.9.8–
CVE-2026-35168OpenSTAManager: SQL Injection via Aggiornamenti Modulehigh8.8<2.10.22.10.2
CVE-2026-29782OpenSTAManager Affected by Remote Code Execution via Insecure Deserialization in OAuth2high7.2<2.10.22.10.2
CVE-2026-27012OpenSTAManager affected by unauthenticated privilege escalation via modules/utenti/actions.phpcritical9.8<=2.9.8–
CVE-2025-69214OpenSTAManager has a SQL Injection in ajax_select.php (componenti endpoint)high8.8<=2.9.8–
CVE-2026-38751OpenSTAManager contains an arbitrary file upload vulnerability in its module update functionalityhigh7.2<=2.10-beta–
CVE-2026-28805OpenSTAManager has a Time-Based Blind SQL Injection via `options[stato]` Parameterhigh8.8<2.10.22.10.2
CVE-2025-69213OpenSTAManager has a SQL Injection in ajax_complete.php (get_sedi endpoint)high0.0<=2.9.8–
CVE-2025-69215OpenSTAManager has an SQL Injection in the Stampe Modulehigh0.0<=2.9.8–
CVE-2026-35470OpenSTAManager has a SQL Injection via righe Parameter in confronta_righe Modalshigh8.8<2.10.22.10.2
CVE-2026-24416OpenSTAManager has a Time-Based Blind SQL Injection in Article Pricing Modulehigh0.0<=2.9.8–
CVE-2026-24417OpenSTAManager has a Time-Based Blind SQL Injection with Amplified Denial of Servicehigh0.0all versions–
CVE-2026-24418OpenSTAManager has a SQL Injection vulnerability in the Scadenzario bulk operations modulehigh0.0<=2.9.8–
CVE-2025-69216OpenSTAManager has a SQL Injection in Scadenzario Print Templatehigh0.0<=2.9.8–
CVE-2026-24419OpenSTAManager has a SQL Injection in the Prima Nota modulehigh0.0<=2.9.8–
CVE-2025-65103OpenSTAManager has Authenticated SQL Injection in API via 'display' parameterhigh8.8<2.9.52.9.5
CVE-2026-24415OpenSTAManager Affected by XSS in modifica_iva.php via righe parametermedium0.0<2.9.82.9.8
CVE-2026-44701OpenSTAManager has HTML Injection in modules/utenti/edit.phplow3.5<2.11-beta2.11-beta

Am I affected?

Find out in one command. phpwarden checks your composer.lock against this advisory and 20,000+ others, ranked by real-world exploitation (CISA KEV + EPSS). Free, offline, open data.

# one-time install
pip install phpwarden

# then
phpwarden deps composer.lock

Or keep it checked automatically: GitHub Action · pre-commit hook · GitLab CI · Laravel artisan command

Install docs   How findings are ranked
A version is vulnerable when it falls inside an affected range and below the fixed version. phpwarden applies these ranges to the exact versions in your lockfile or install, so you only see what applies to you.