Is mautic/core-lib vulnerable?

Composer mautic/core-lib has 5 known advisories in the phpwarden feed. Feed 2026.10.29.1, updated 2026-10-28.

5advisories
0critical
0on CISA KEV
0no fix recorded
CVETitleSeverityCVSSAffectedFixed in
CVE-2024-47050Mautic vulnerable to XSS in contact/company tracking (no authentication)medium5.4>=2.6.0 and <4.4.13 or >=5.0.0-alpha and <5.1.14.4.13, 5.1.1
CVE-2021-27917Mautic has an XSS in contact tracking and page hits reporthigh7.3>=1.0.0-beta4 and <4.4.13 or >=5.0.0-alpha and <5.1.14.4.13, 5.1.1
CVE-2022-25768Mautic vulnerable to Improper Access Control in UI upgrade processhigh7.0>=1.1.3 and <4.4.13 or >=5.0.0-alpha and <5.1.14.4.13, 5.1.1
CVE-2022-25770Mautic has insufficient authentication in upgrade flowhigh7.8>=1.0.0-beta3 and <4.4.13 or >=5.0.0-alpha and <5.1.14.4.13, 5.1.1
CVE-2024-47058Mautic vulnerable to Cross-site Scripting (XSS) - stored (edit form HTML field)medium4.8>=5.0.0-alpha and <5.1.1 or >=1.0.0-beta and <4.4.135.1.1, 4.4.13

Am I affected?

Find out in one command. phpwarden checks your composer.lock against this advisory and 20,000+ others, ranked by real-world exploitation (CISA KEV + EPSS). Free, offline, open data.

# one-time install
pip install phpwarden

# then
phpwarden deps composer.lock

Or keep it checked automatically: GitHub Action · pre-commit hook · GitLab CI · Laravel artisan command

Install docs   How findings are ranked
A version is vulnerable when it falls inside an affected range and below the fixed version. phpwarden applies these ranges to the exact versions in your lockfile or install, so you only see what applies to you.