Is openmage/magento-lts vulnerable?

Composer openmage/magento-lts has 26 known advisories in the phpwarden feed. Feed 2026.10.29.1, updated 2026-10-28.

26advisories
3critical
0on CISA KEV
0no fix recorded
CVETitleSeverityCVSSAffectedFixed in
CVE-2021-32758Layout XML Arbitrary Code Fixhigh0.0<19.4.15 or >=20.0.0 and <20.0.1319.4.15, 20.0.13
CVE-2021-32759Data Flow Sanitation Issue Fixhigh0.0<19.4.15 or >=20.0.0 and <20.0.1319.4.15, 20.0.13
CVE-2021-39217Fix for arbitrary command execution in custom layout update through blockshigh7.2<19.4.22 or >=20.0.0 and <20.0.1919.4.22, 20.0.19
CVE-2021-41143Fix for arbitrary file deletion in customer media allows for remote code executionhigh7.2<19.4.22 or >=20.0.0 and <20.0.1919.4.22, 20.0.19
CVE-2020-15244RCE via PHP Object injection via SOAP Requestshigh8.0<19.4.8 or >=20.0.0 and <20.0.419.4.8, 20.0.4
CVE-2023-41879Magento LTS's guest order "protect code" can be brute-forced too easilyhigh7.5<19.5.1 or >=20.0.0 and <20.1.119.5.1, 20.1.1
CVE-2021-41231DataFlow upload remote code execution vulnerabilityhigh7.2<19.4.22 or >=20.0.0 and <20.0.1919.4.22, 20.0.19
CVE-2021-21426Fixes a bug in Zend Framework's Stream HTTP Wrappercritical9.8<19.4.13 or >=20.0.0 and <20.0.919.4.13, 20.0.9
CVE-2021-41144Fix for authenticated remote code execution through layout updatehigh8.8<19.4.22 or >=20.0.0 and <20.0.1919.4.22, 20.0.19
CVE-2021-21427Backport for CVE-2021-21024 Blind SQLi from Magento 2critical9.1<19.4.13 or >=20.0.0 and <20.0.919.4.13, 20.0.9
CVE-2023-23617DoS vulnerability in MaliciousCode filtermedium4.9<19.4.22 or >=20.0.0 and <20.0.1919.4.22, 20.0.19
CVE-2020-15151Observable Timing Discrepancy in OpenMage LTShigh8.0<19.4.6 or >=20.0.0 and <20.0.219.4.6, 20.0.2
CVE-2026-40488OpenMage LTS: Customer File Upload Extension Blocklist Bypass → Remote Code Executionhigh8.8<20.17.020.17.0
CVE-2026-25524OpenMage LTS: Phar Deserialization leads to Remote Code Executionhigh8.1<20.17.020.17.0
CVE-2026-25525OpenMage LTS has a Path Traversal Filter Bypass in Dataflow Modulemedium4.9<20.17.020.17.0
CVE-2021-21395magento-lts Reset Password not protected against well-timed CSRFmedium4.3<19.4.22 or >=20.0.0 and <20.0.1919.4.22, 20.0.19
CVE-2026-42155Magento LTS has Weak API Session ID — Predictable MD5 of Time-Derived Inputscritical0.0<20.18.020.18.0
CVE-2024-41676Magento LTS vulnerable to stored Cross-site Scripting (XSS) in admin system configsmedium4.1<20.10.120.10.1
CVE-2026-25523Magento's X-Original-Url header can expose admin urlmedium5.3<20.16.120.16.1
CVE-2026-42458Magento LTS: Reflected XSS - Import -> Data Flow (profiles)medium0.0<20.18.020.18.0
CVE-2025-27400Magento LTS vulnerable to stored XSS in theme config fieldslow2.9<20.12.320.12.3
CVE-2025-64174OpenMage vulnerable to XSS in Admin Notificationsmedium0.0<20.16.020.16.0
CVE-2026-40098OpenMage LTS: Cross-user wishlist import leads to private option & file disclosuremedium5.4<20.17.020.17.0
CVE-2026-42207Magento LTS Vulnerable to Open Redirect via Unvalidated `uenc` Parameter in `stockAction()`medium6.1<20.18.020.18.0
GHSA-9j5w-2cqc-cwj9Magento LTS vulnerable to Stored XSS via TinyMCE WYSIWYG Editorhigh7.5<20.2.020.2.0
GHSA-gp6m-fq6h-cjcxMagento LTS vulnerable to stored XSS in admin file formmedium5.4>=20.0.0 and <20.5.0 or <19.5.320.5.0, 19.5.3

Am I affected?

Find out in one command. phpwarden checks your composer.lock against this advisory and 20,000+ others, ranked by real-world exploitation (CISA KEV + EPSS). Free, offline, open data.

# one-time install
pip install phpwarden

# then
phpwarden deps composer.lock

Or keep it checked automatically: GitHub Action · pre-commit hook · GitLab CI · Laravel artisan command

Install docs   How findings are ranked
A version is vulnerable when it falls inside an affected range and below the fixed version. phpwarden applies these ranges to the exact versions in your lockfile or install, so you only see what applies to you.