Is forminator (WordPress plugin) vulnerable?

WordPress forminator has 23 known advisories in the phpwarden feed. Feed 2026.10.29.1, updated 2026-10-28.

23advisories
1critical
0on CISA KEV
3no fix recorded
CVETitleSeverityCVSSAffectedFixed in
CVE-2025-6463The Forminator Forms – Contact Form, Payment Form & Custom Form Builder plugin for WordPress is vulnerable to arbitrary file deletion due tohigh8.8<1.44.31.44.3
CVE-2023-4596The Forminator plugin for WordPress is vulnerable to arbitrary file uploads due to file type validation occurring after a file has been uplocritical9.8<=1.24.6–
CVE-2023-3134The Forminator WordPress plugin before 1.24.4 does not properly escape values that are being reflected inside form fields that use pre-populmedium6.1<1.24.41.24.4
CVE-2019-9568The "Forminator Contact Form, Poll & Quiz Builder" plugin before 1.6 for WordPress has SQL Injection via the wp-admin/admin.php?page=forminamedium6.5<1.61.6
CVE-2019-9567The "Forminator Contact Form, Poll & Quiz Builder" plugin before 1.6 for WordPress has XSS via a custom input field of a poll.medium6.1<1.61.6
CVE-2023-6133The Forminator plugin for WordPress is vulnerable to arbitrary file uploads due to insufficient blacklisting on the 'forminator_allowed_mimemedium6.6<=1.27.0–
CVE-2024-7389The Forminator plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.29.1 via class-fhigh7.5<1.29.21.29.2
CVE-2021-24700The Forminator WordPress plugin before 1.15.4 does not sanitize and escape the email field label, which could allow high privilege users to medium4.8<1.15.41.15.4
CVE-2025-6464The Forminator Forms – Contact Form, Payment Form & Custom Form Builder plugin for WordPress is vulnerable to PHP Object Injection in all vehigh7.5<1.44.31.44.3
CVE-2024-1794The Forminator plugin for WordPress is vulnerable to Stored Cross-Site Scripting via an uploaded file (e.g. 3gpp file) in all versions up tohigh7.2<=1.29.1–
CVE-2023-5119The Forminator WordPress plugin before 1.27.0 does not properly sanitize the redirect-url field in the form submission settings, which couldmedium4.8<1.27.01.27.0
CVE-2024-29777Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPMU DEV - Your All-in-One WordPress Phigh7.1<1.29.11.29.1
CVE-2021-4417The Forminator – Contact Form, Payment Form & Custom Form Builder plugin for WordPress is vulnerable to Cross-Site Request Forgery in versiomedium5.4<1.13.51.13.5
CVE-2024-9700The Forminator Forms – Contact Form, Payment Form & Custom Form Builder plugin for WordPress is vulnerable to Insecure Direct Object Referenmedium5.3<1.36.11.36.1
CVE-2023-2010The Forminator WordPress plugin before 1.24.1 does not use an atomic operation to check whether a user has already voted, and then update thlow3.1<1.24.11.24.1
CVE-2024-3053The Forminator – Contact Form, Payment Form & Custom Form Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the medium6.4<1.29.31.29.3
CVE-2025-0470The Forminator Forms – Contact Form, Payment Form & Custom Form Builder plugin for WordPress is vulnerable to Reflected Cross-Site Scriptingmedium6.1<1.38.31.38.3
CVE-2025-3487The Forminator Forms – Contact Form, Payment Form & Custom Form Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting vimedium6.4<1.42.11.42.1
CVE-2025-5341The Forminator Forms – Contact Form, Payment Form & Custom Form Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting vimedium6.4<1.44.21.44.2
CVE-2025-0469The Forminator Forms – Contact Form, Payment Form & Custom Form Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting vimedium6.4<1.39.31.39.3
CVE-2024-9351The Forminator Forms – Contact Form, Payment Form & Custom Form Builder plugin for WordPress is vulnerable to Cross-Site Request Forgery in medium4.3<1.36.01.36.0
CVE-2024-9352The Forminator Forms – Contact Form, Payment Form & Custom Form Builder plugin for WordPress is vulnerable to Cross-Site Request Forgery in medium4.3<1.36.01.36.0
CVE-2025-3479The Forminator Forms – Contact Form, Payment Form & Custom Form Builder plugin for WordPress is vulnerable to Order Replay in all versions umedium5.3<1.42.11.42.1

Am I affected?

Find out in one command. phpwarden checks your WordPress install against this advisory and 20,000+ others, ranked by real-world exploitation (CISA KEV + EPSS). Free, offline, open data.

# one-time install
pip install phpwarden

# then
phpwarden wordpress /var/www/html

Or keep it checked automatically with the GitHub Action or a nightly cron; see WordPress docs.

Install docs   How findings are ranked
A version is vulnerable when it falls inside an affected range and below the fixed version. phpwarden applies these ranges to the exact versions in your lockfile or install, so you only see what applies to you.