Is metform (WordPress plugin) vulnerable?

WordPress metform has 21 known advisories in the phpwarden feed. Feed 2026.10.29.1, updated 2026-10-28.

21advisories
0critical
0on CISA KEV
14no fix recorded
CVETitleSeverityCVSSAffectedFixed in
CVE-2023-0084The Metform Elementor Contact Form Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via text areas on forms in vershigh7.2<=3.1.2–
CVE-2022-1442The Metform WordPress plugin is vulnerable to sensitive information disclosure due to improper access control in the ~/core/forms/action.phphigh7.5<2.1.42.1.4
CVE-2023-0714The Metform Elementor Contact Form Builder for WordPress is vulnerable to Arbitrary File Upload due to insufficient file type validation in high8.1<3.3.03.3.0
CVE-2023-0688The Metform Elementor Contact Form Builder for WordPress is vulnerable to Information Disclosure via the 'mf_thankyou' shortcode in versionsmedium6.5<=3.3.1–
CVE-2023-0721The Metform Elementor Contact Form Builder plugin for WordPress is vulnerable to CSV injection in versions up to, and including, 3.3.0. Thishigh8.3<=3.3.0–
CVE-2023-0085The Metform Elementor Contact Form Builder plugin for WordPress is vulnerable to reCaptcha Bypass in versions up to, and including, 3.2.1. Tmedium5.3<=3.2.1–
CVE-2023-0693The Metform Elementor Contact Form Builder for WordPress is vulnerable to Information Disclosure via the 'mf_transaction_id' shortcode in vemedium6.5<=3.3.1–
CVE-2023-0694The Metform Elementor Contact Form Builder for WordPress is vulnerable to Information Disclosure via the 'mf' shortcode in versions up to, amedium6.5<=3.3.1–
CVE-2023-1843The Metform Elementor Contact Form Builder plugin for WordPress is vulnerable to unauthorized permalink structure update due to a missing camedium6.5<=3.3.0–
CVE-2023-0691The Metform Elementor Contact Form Builder for WordPress is vulnerable to Information Disclosure via the 'mf_last_name' shortcode in versionmedium4.3<=3.3.1–
CVE-2023-0692The Metform Elementor Contact Form Builder for WordPress is vulnerable to Information Disclosure via the 'mf_payment_status' shortcode in vemedium4.3<=3.3.1–
CVE-2023-0689The Metform Elementor Contact Form Builder for WordPress is vulnerable to Information Disclosure via the 'mf_first_name' shortcode in versiomedium4.3<3.3.23.3.2
CVE-2023-0708The Metform Elementor Contact Form Builder for WordPress is vulnerable to Cross-Site Scripting by using the 'mf_first_name' shortcode to echmedium5.4<=3.3.0–
CVE-2023-0709The Metform Elementor Contact Form Builder for WordPress is vulnerable to Cross-Site Scripting by using the 'mf_last_name' shortcode to echomedium5.4<=3.3.0–
CVE-2024-4266The MetForm – Contact Form, Survey, Quiz, & Custom Form Builder for Elementor plugin for WordPress is vulnerable to Sensitive Information Exmedium5.3<3.8.93.8.9
CVE-2024-1585The Metform Elementor Contact Form Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's shortcode(s) imedium6.4<3.8.43.8.4
CVE-2023-0695The Metform Elementor Contact Form Builder for WordPress is vulnerable to Cross-Site Scripting by using the 'mf' shortcode to echo unescapedmedium5.4<=3.3.0–
CVE-2023-2517The Metform Elementor Contact Form Builder plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and includingmedium5.4<3.3.33.3.3
CVE-2023-0710The Metform Elementor Contact Form Builder for WordPress is vulnerable to Cross-Site Scripting by using the 'fname' attribute of the 'mf_thamedium4.9<=3.3.0–
CVE-2024-2791The Metform Elementor Contact Form Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's widgets in allmedium6.4<3.8.63.8.6
CVE-2023-6788The Metform Elementor Contact Form Builder plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and inclumedium5.4<=3.8.1–

Am I affected?

Find out in one command. phpwarden checks your WordPress install against this advisory and 20,000+ others, ranked by real-world exploitation (CISA KEV + EPSS). Free, offline, open data.

# one-time install
pip install phpwarden

# then
phpwarden wordpress /var/www/html

Or keep it checked automatically with the GitHub Action or a nightly cron; see WordPress docs.

Install docs   How findings are ranked
A version is vulnerable when it falls inside an affected range and below the fixed version. phpwarden applies these ranges to the exact versions in your lockfile or install, so you only see what applies to you.