Is mstore-api (WordPress plugin) vulnerable?

WordPress mstore-api has 25 known advisories in the phpwarden feed. Feed 2026.10.29.1, updated 2026-10-28.

25advisories
10critical
0on CISA KEV
12no fix recorded
CVETitleSeverityCVSSAffectedFixed in
CVE-2023-2732The MStore API plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 3.9.2. This is due to insufficicritical9.8<=3.9.2–
CVE-2023-3077The MStore API WordPress plugin before 3.9.8 does not sanitise and escape a parameter before using it in a SQL statement, leading to a Blindcritical9.8<3.9.83.9.8
CVE-2023-3197The MStore API plugin for WordPress is vulnerable to Unauthenticated Blind SQL Injection via the 'id' parameter in versions up to, and inclucritical9.8<=4.0.1–
CVE-2023-2734The MStore API plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 3.9.1. This is due to insufficicritical9.8<=3.9.1–
CVE-2021-24148A business logic issue in the MStore API WordPress plugin, versions before 3.2.0, had an authentication bypass with Sign In With Apple allowcritical9.8<3.2.03.2.0
CVE-2023-3277The MStore API plugin for WordPress is vulnerable to Unauthorized Account Access and Privilege Escalation in versions up to, and including, critical9.8<=4.10.7–
CVE-2023-3076The MStore API WordPress plugin before 3.9.9 does not prevent visitors from creating user accounts with the role of their choice via their wcritical9.8<3.9.93.9.9
CVE-2020-36713The MStore API plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 2.1.5. This is due to unrestriccritical9.8<=2.1.5–
CVE-2023-2733The MStore API plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 3.9.0. This is due to insufficicritical9.8<=3.9.0–
CVE-2024-8242The MStore API – Create Native Android & iOS Apps On The Cloud plugin for WordPress is vulnerable to arbitrary file uploads due to missing fmedium4.3<4.15.44.15.4
CVE-2024-6328The MStore API – Create Native Android & iOS Apps On The Cloud plugin for WordPress is vulnerable to authentication bypass in all versions ucritical9.8<4.15.04.15.0
CVE-2024-7628The MStore API – Create Native Android & iOS Apps On The Cloud plugin for WordPress is vulnerable to authentication bypass in versions up tohigh8.1<4.15.34.15.3
CVE-2023-3131The MStore API WordPress plugin before 3.9.7 does not secure most of its AJAX actions by implementing privilege checks, nonce checks, or a cmedium4.3<3.9.73.9.7
CVE-2024-11179The MStore API – Create Native Android & iOS Apps On The Cloud plugin for WordPress is vulnerable to SQL Injection via the 'status_type' parmedium6.5<4.15.84.15.8
CVE-2024-8269The MStore API – Create Native Android & iOS Apps On The Cloud plugin for WordPress is vulnerable to unauthorized user registration in all vhigh7.3<4.15.44.15.4
CVE-2025-3438The MStore API – Create Native Android & iOS Apps On The Cloud plugin for WordPress is vulnerable to limited privilege escalation in all vermedium6.5<4.17.54.17.5
CVE-2024-12042The MStore API – Create Native Android & iOS Apps On The Cloud plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the promedium5.4<4.16.54.16.5
CVE-2023-3198The MStore API plugin for WordPress is vulnerable to Cross-Site Request Forgery due to missing nonce validation on the mstore_update_status_medium4.3<=3.9.6–
CVE-2023-3200The MStore API plugin for WordPress is vulnerable to Cross-Site Request Forgery due to missing nonce validation on the mstore_update_new_ordmedium4.3<=3.9.6–
CVE-2023-3201The MStore API plugin for WordPress is vulnerable to Cross-Site Request Forgery due to missing nonce validation on the mstore_update_new_ordmedium4.3<=3.9.6–
CVE-2023-3203The MStore API plugin for WordPress is vulnerable to Cross-Site Request Forgery due to missing nonce validation on the mstore_update_limit_pmedium4.3<=3.9.6–
CVE-2025-4683The MStore API – Create Native Android & iOS Apps On The Cloud plugin for WordPress is vulnerable to unauthorized modification of data due tmedium4.3<4.17.64.17.6
CVE-2023-3199The MStore API plugin for WordPress is vulnerable to Cross-Site Request Forgery due to missing nonce validation on the mstore_update_status_medium4.3<=3.9.6–
CVE-2023-3202The MStore API plugin for WordPress is vulnerable to Cross-Site Request Forgery due to missing nonce validation on the mstore_update_firebasmedium4.3<=3.9.6–
CVE-2023-3209The MStore API WordPress plugin before 3.9.7 does not secure most of its AJAX actions by implementing privilege checks, nonce checks, or a clow3.5<3.9.73.9.7

Am I affected?

Find out in one command. phpwarden checks your WordPress install against this advisory and 20,000+ others, ranked by real-world exploitation (CISA KEV + EPSS). Free, offline, open data.

# one-time install
pip install phpwarden

# then
phpwarden wordpress /var/www/html

Or keep it checked automatically with the GitHub Action or a nightly cron; see WordPress docs.

Install docs   How findings are ranked
A version is vulnerable when it falls inside an affected range and below the fixed version. phpwarden applies these ranges to the exact versions in your lockfile or install, so you only see what applies to you.