Is optinmonster (WordPress plugin) vulnerable?

WordPress optinmonster has 5 known advisories in the phpwarden feed. Feed 2026.10.29.1, updated 2026-10-28.

5advisories
0critical
0on CISA KEV
2no fix recorded
CVETitleSeverityCVSSAffectedFixed in
CVE-2021-39341The OptinMonster WordPress plugin is vulnerable to sensitive information disclosure and unauthorized setting updates due to insufficient authigh8.2<=2.6.4–
CVE-2016-10996The optinmonster plugin before 1.1.4.6 for WordPress has incorrect access control for shortcodes because of a nonce leak.medium5.3<1.1.4.61.1.4.6
CVE-2021-39325The OptinMonster WordPress plugin is vulnerable to Reflected Cross-Site Scripting due to insufficient input validation in the load_previews medium6.1<=2.6.0–
CVE-2023-0772The Popup Builder by OptinMonster WordPress plugin before 2.12.2 does not ensure that the campaign to be loaded via some shortcodes is actuamedium6.5<2.12.22.12.2
CVE-2024-4045The Popup Builder by OptinMonster – WordPress Popups for Optins, Email Newsletters and Lead Generation plugin for WordPress is vulnerable tomedium6.4<2.16.22.16.2

Am I affected?

Find out in one command. phpwarden checks your WordPress install against this advisory and 20,000+ others, ranked by real-world exploitation (CISA KEV + EPSS). Free, offline, open data.

# one-time install
pip install phpwarden

# then
phpwarden wordpress /var/www/html

Or keep it checked automatically with the GitHub Action or a nightly cron; see WordPress docs.

Install docs   How findings are ranked
A version is vulnerable when it falls inside an affected range and below the fixed version. phpwarden applies these ranges to the exact versions in your lockfile or install, so you only see what applies to you.