Is pagelayer (WordPress plugin) vulnerable?

WordPress pagelayer has 15 known advisories in the phpwarden feed. Feed 2026.10.29.1, updated 2026-10-28.

15advisories
0critical
0on CISA KEV
1no fix recorded
CVETitleSeverityCVSSAffectedFixed in
CVE-2020-35947An issue was discovered in the PageLayer plugin before 1.1.2 for WordPress. Nearly all of the AJAX action endpoints lacked permission checkshigh7.4<1.1.21.1.2
CVE-2020-35944An issue was discovered in the PageLayer plugin before 1.1.2 for WordPress. The pagelayer_settings_page function is vulnerable to CSRF, whichigh8.8<1.1.21.1.2
CVE-2023-4687The Page Builder: Pagelayer WordPress plugin before 1.7.7 doesn't prevent unauthenticated attackers from updating a post's header or footer medium6.1<1.7.71.7.7
CVE-2023-5087The Page Builder: Pagelayer WordPress plugin before 1.7.8 doesn't prevent attackers with author privileges and higher from inserting maliciomedium5.4<1.7.81.7.8
CVE-2024-2504The Page Builder: Pagelayer – Drag and Drop website builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'attr'medium6.4<1.8.51.8.5
CVE-2023-6738The Page Builder: Pagelayer – Drag and Drop website builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'pagelmedium5.4<=1.7.8–
CVE-2023-7115The Page Builder: Pagelayer WordPress plugin before 1.8.1 does not sanitise and escape some of its settings, which could allow high privilegmedium4.8<1.8.11.8.1
CVE-2023-5124The Page Builder: Pagelayer WordPress plugin before 1.8.0 doesn't prevent attackers with administrator privileges from inserting malicious Jmedium4.8<1.8.01.8.0
CVE-2024-1590The Page Builder: Pagelayer – Drag and Drop website builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the pluginmedium4.6<1.8.31.8.3
CVE-2024-8618The Page Builder: Pagelayer WordPress plugin before 1.9.0 does not sanitise and escape some of its settings, which could allow high privilemedium4.8<1.9.01.9.0
CVE-2024-2127The Page Builder: Pagelayer – Drag and Drop website builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via custom attmedium6.4<1.8.41.8.4
CVE-2024-13430The Page Builder: Pagelayer – Drag and Drop website builder plugin for WordPress is vulnerable to Information Exposure in all versions up tomedium4.3<1.9.91.9.9
CVE-2024-8426The Page Builder: Pagelayer WordPress plugin before 1.8.8 does not sanitise and escape some of its settings, which could allow high privilemedium4.8<1.8.81.8.8
CVE-2025-2104The Page Builder: Pagelayer – Drag and Drop website builder plugin for WordPress is vulnerable to unauthorized post publication due to insufmedium4.3<2.0.02.0.0
CVE-2025-1926The Page Builder: Pagelayer – Drag and Drop website builder plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versionsmedium4.3<1.9.91.9.9

Am I affected?

Find out in one command. phpwarden checks your WordPress install against this advisory and 20,000+ others, ranked by real-world exploitation (CISA KEV + EPSS). Free, offline, open data.

# one-time install
pip install phpwarden

# then
phpwarden wordpress /var/www/html

Or keep it checked automatically with the GitHub Action or a nightly cron; see WordPress docs.

Install docs   How findings are ranked
A version is vulnerable when it falls inside an affected range and below the fixed version. phpwarden applies these ranges to the exact versions in your lockfile or install, so you only see what applies to you.