Is popup-builder (WordPress plugin) vulnerable?

WordPress popup-builder has 18 known advisories in the phpwarden feed. Feed 2026.10.29.1, updated 2026-10-28.

18advisories
3critical
0on CISA KEV
3no fix recorded
CVETitleSeverityCVSSAffectedFixed in
CVE-2022-0479The Popup Builder WordPress plugin before 4.1.1 does not sanitise and escape the sgpb-subscription-popup-id parameter before using it in a Scritical9.8<4.1.14.1.1
CVE-2020-9006The Popup Builder plugin 2.2.8 through 2.6.7.6 for WordPress is vulnerable to SQL injection (in the sgImportPopups function in sg_popup_ajaxcritical9.8>=2.2.8 and <=2.6.7.6–
CVE-2022-0228The Popup Builder WordPress plugin before 4.0.7 does not validate and properly escape the orderby and order parameters before using them in high7.2<4.0.74.0.7
CVE-2021-25082The Popup Builder WordPress plugin before 4.0.7 does not validate and sanitise the sgpb_type parameter before using it in a require statemenhigh8.8<4.0.74.0.7
CVE-2019-14695A SQL injection vulnerability exists in the Sygnoos Popup Builder plugin before 3.45 for WordPress. Successful exploitation of this vulnerabcritical9.8<3.453.45
CVE-2023-6000The Popup Builder WordPress plugin before 4.2.3 does not prevent simple visitors from updating existing popups, and injecting raw JavaScriptmedium6.1<4.2.34.2.3
CVE-2020-10196An XSS vulnerability in the popup-builder plugin before 3.64.1 for WordPress allows remote attackers to inject arbitrary JavaScript into eximedium6.1<3.64.13.64.1
CVE-2020-10195The popup-builder plugin before 3.64.1 for WordPress allows information disclosure and settings modification, leading to in-scope privilege medium6.3<3.64.13.64.1
CVE-2023-6294The Popup Builder WordPress plugin before 4.2.6 does not validate a parameter before making a request to it, which could allow users with thhigh7.2<4.2.64.2.6
CVE-2022-1894The Popup Builder WordPress plugin before 4.1.11 does not escape and sanitize some settings, which could allow high privilege users to perfomedium4.8<4.1.114.1.11
CVE-2024-2541The Popup Builder plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.3.6 via the Smedium5.3<=4.3.3–
CVE-2022-29495Cross-Site Request Forgery (CSRF) vulnerability in Sygnoos Popup Builder plugin <= 4.1.11 at WordPress allows an attacker to update plugin smedium5.4<4.1.124.1.12
CVE-2023-6696The Popup Builder – Create highly converting, mobile friendly marketing popups. plugin for WordPress is vulnerable to unauthorized access ofhigh8.1<4.3.24.3.2
CVE-2023-3226The Popup Builder WordPress plugin before 4.2.0 does not sanitise and escape some of its settings, which could allow high privilege users sumedium4.8<=4.1.15–
CVE-2024-9428The Popup Builder WordPress plugin before 4.3.5 does not sanitise and escape some of its settings, which could allow high privilege users smedium4.8<4.3.54.3.5
CVE-2022-32289Cross-Site Request Forgery (CSRF) vulnerability in Sygnoos Popup Builder plugin <= 4.1.0 at WordPress leading to popup status change.medium5.4<4.1.14.1.1
CVE-2024-3236The Popup Builder WordPress plugin before 1.1.33 does not sanitise and escape some of its Notification fields, which could allow users such medium5.4<1.1.331.1.33
CVE-2024-2544The Popup Builder plugin for WordPress is vulnerable to unauthorized modification of data and loss of data due to a missing capability checkhigh7.4<4.3.24.3.2

Am I affected?

Find out in one command. phpwarden checks your WordPress install against this advisory and 20,000+ others, ranked by real-world exploitation (CISA KEV + EPSS). Free, offline, open data.

# one-time install
pip install phpwarden

# then
phpwarden wordpress /var/www/html

Or keep it checked automatically with the GitHub Action or a nightly cron; see WordPress docs.

Install docs   How findings are ranked
A version is vulnerable when it falls inside an affected range and below the fixed version. phpwarden applies these ranges to the exact versions in your lockfile or install, so you only see what applies to you.