Is ulisting (WordPress plugin) vulnerable?

WordPress ulisting has 18 known advisories in the phpwarden feed. Feed 2026.10.29.1, updated 2026-10-28.

18advisories
8critical
0on CISA KEV
17no fix recorded
CVETitleSeverityCVSSAffectedFixed in
CVE-2021-36879Unauthenticated Privilege Escalation vulnerability in WordPress uListing plugin (versions <= 2.0.5). Possible if WordPress configuration allcritical9.8<=2.0.5–
CVE-2021-36880Unauthenticated SQL Injection (SQLi) vulnerability in WordPress uListing plugin (versions <= 2.0.3), vulnerable parameter: custom.high8.6<=2.0.3–
CVE-2021-4343The Unauthenticated Account Creation plugin for WordPress is vulnerable to Unauthenticated Account Creation in versions up to, and includingcritical9.8<=1.6.6–
CVE-2021-4370The uListing plugin for WordPress is vulnerable to authorization bypass as most actions and endpoints are accessible to unauthenticated usercritical9.8<=1.6.6–
CVE-2021-4381The uListing plugin for WordPress is vulnerable to authorization bypass via wp_route due to missing capability checks, and a missing securitcritical9.8<1.71.7
CVE-2021-4346The uListing plugin for WordPress is vulnerable to Unauthenticated Arbitrary Account Changes in versions up to, and including, 1.6.6. This icritical9.8<=1.6.6–
CVE-2021-4340The uListing plugin for WordPress is vulnerable to generic SQL Injection via the ‘listing_id’ parameter in versions up to, and including, 1.critical9.8<=1.6.6–
CVE-2021-4341The uListing plugin for WordPress is vulnerable to authorization bypass via Ajax due to missing capability checks, missing input validation,critical9.8<=1.6.6–
CVE-2021-36874Authenticated Insecure Direct Object References (IDOR) vulnerability in WordPress uListing plugin (versions <= 2.0.5).high7.1<=2.0.5–
CVE-2021-4357The uListing plugin for WordPress is vulnerable to authorization bypass due to missing capability checks, and a missing security nonce, on tcritical9.1<=1.6.6–
CVE-2021-4339The uListing plugin for WordPress is vulnerable to authorization bypass due to a missing capability check in the "ulisting/includes/route.phhigh7.5<=1.6.6–
CVE-2021-36875Cross-site Scripting (XSS) vulnerability in Stylemix Directory Listings WordPress plugin – uListing allows Reflected XSS.This issue affects medium5.9<=2.0.5–
CVE-2021-4345The uListing plugin for WordPress is vulnerable to authorization bypass due to missing capability and nonce checks on the UlistingUserRole::medium6.5<=1.6.6–
CVE-2025-1653The Directory Listings WordPress plugin – uListing plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and inchigh8.8<=2.1.7–
CVE-2021-36876Multiple Cross-Site Request Forgery (CSRF) vulnerabilities in WordPress uListing plugin (versions <= 2.0.5) as it lacks CSRF checks on plugimedium5.4<=2.0.5–
CVE-2021-36877Cross-Site Request Forgery (CSRF) vulnerability in WordPress uListing plugin (versions <= 2.0.5) makes it possible for attackers to modify umedium4.3<=2.0.5–
CVE-2021-36878Cross-Site Request Forgery (CSRF) vulnerability in WordPress uListing plugin (versions <= 2.0.5) makes it possible for attackers to update smedium4.3<=2.0.5–
CVE-2025-1657The Directory Listings WordPress plugin – uListing plugin for WordPress is vulnerable to unauthorized modification of data and PHP Object Inhigh8.8<=2.1.7–

Am I affected?

Find out in one command. phpwarden checks your WordPress install against this advisory and 20,000+ others, ranked by real-world exploitation (CISA KEV + EPSS). Free, offline, open data.

# one-time install
pip install phpwarden

# then
phpwarden wordpress /var/www/html

Or keep it checked automatically with the GitHub Action or a nightly cron; see WordPress docs.

Install docs   How findings are ranked
A version is vulnerable when it falls inside an affected range and below the fixed version. phpwarden applies these ranges to the exact versions in your lockfile or install, so you only see what applies to you.