Is ultimate-member (WordPress plugin) vulnerable?

WordPress ultimate-member has 42 known advisories in the phpwarden feed. Feed 2026.10.29.1, updated 2026-10-28.

42advisories
5critical
0on CISA KEV
8no fix recorded
CVETitleSeverityCVSSAffectedFixed in
CVE-2024-1071The Ultimate Member – User Profile, Registration, Login, Member Directory, Content Restriction & Membership Plugin plugin for WordPress is vcritical9.8>=2.1.3 and <2.8.32.8.3
CVE-2023-3460The Ultimate Member WordPress plugin before 2.6.7 does not prevent visitors from creating user accounts with arbitrary capabilities, effecticritical9.8<2.6.72.6.7
CVE-2024-2123The Ultimate Member – User Profile, Registration, Login, Member Directory, Content Restriction & Membership Plugin plugin for WordPress is vhigh7.2<2.8.42.8.4
CVE-2020-36155An issue was discovered in the Ultimate Member plugin before 2.1.12 for WordPress, aka Unauthenticated Privilege Escalation via User Meta. Acritical10.0<2.1.122.1.12
CVE-2022-3383The Ultimate Member plugin for WordPress is vulnerable to Remote Code Execution in versions up to, and including, 2.5.0 via the get_option_vhigh7.2<=2.5.0–
CVE-2022-3384The Ultimate Member plugin for WordPress is vulnerable to Remote Code Execution in versions up to, and including, 2.5.0 via the populate_drohigh7.2<=2.5.0–
CVE-2020-36157An issue was discovered in the Ultimate Member plugin before 2.1.12 for WordPress, aka Unauthenticated Privilege Escalation via User Roles. critical10.0<2.1.122.1.12
CVE-2022-3361The Ultimate Member plugin for WordPress is vulnerable to directory traversal in versions up to, and including 2.5.0 due to insufficient inpmedium4.3<=2.5.0–
CVE-2018-0588Directory traversal vulnerability in the AJAX function of Ultimate Member plugin prior to version 2.0.4 for WordPress allows remote attackerhigh7.5<2.0.42.0.4
CVE-2020-6859Multiple Insecure Direct Object Reference vulnerabilities in includes/core/class-files.php in the Ultimate Member plugin through 2.1.2 for Wmedium5.3<=2.1.2–
CVE-2015-8354Cross-site scripting (XSS) vulnerability in the Ultimate Member WordPress plugin before 1.3.29 for WordPress allows remote attackers to injemedium6.1<=1.3.28–
CVE-2020-36156An issue was discovered in the Ultimate Member plugin before 2.1.12 for WordPress, aka Authenticated Privilege Escalation via Profile Updatecritical9.9<2.1.122.1.12
CVE-2019-10673A CSRF vulnerability in a logged-in user's profile edit form in the Ultimate Member plugin before 2.0.40 for WordPress allows attackers to bhigh8.8<2.0.402.0.40
CVE-2018-17866Multiple cross-site scripting (XSS) vulnerabilities in includes/core/um-actions-login.php in the "Ultimate Member - User Profile & Membershimedium6.1<2.0.282.0.28
CVE-2018-0586Directory traversal vulnerability in the shortcodes function of Ultimate Member plugin prior to version 2.0.4 for WordPress allows remote aumedium4.3<2.0.42.0.4
CVE-2018-13136The Ultimate Member (aka ultimatemember) plugin before 2.0.18 for WordPress has XSS via the wp-admin settings screen.medium6.1<2.0.182.0.18
CVE-2019-10270An arbitrary password reset issue was discovered in the Ultimate Member plugin 2.39 for WordPress. It is possible (due to lack of verificatihigh8.8<2.0.402.0.40
CVE-2018-6944core/lib/upload/um-file-upload.php in the UltimateMember plugin 2.0 for WordPress has a cross-site scripting vulnerability because it fails medium6.1=2.0–
CVE-2020-36170The Ultimate Member plugin before 2.1.13 for WordPress mishandles hidden name="timestamp" fields in forms.medium5.3<2.1.132.1.13
CVE-2018-0589Ultimate Member plugin prior to version 2.0.4 for WordPress allows remote authenticated attackers to bypass access restriction to add a new medium4.3<2.0.42.0.4
CVE-2018-0590Ultimate Member plugin prior to version 2.0.4 for WordPress allows remote authenticated attackers to bypass access restriction to modify themedium4.3<2.0.42.0.4
CVE-2015-9304The ultimate-member plugin before 1.3.18 for WordPress has XSS via text input.medium6.1<1.3.181.3.18
CVE-2016-10872The ultimate-member plugin before 1.3.40 for WordPress has XSS on the login form.medium6.1<1.3.401.3.40
CVE-2018-0587Unrestricted file upload vulnerability in Ultimate Member plugin prior to version 2.0.4 for WordPress allows remote authenticated users to umedium4.3<2.0.42.0.4
CVE-2018-20965The ultimate-member plugin before 2.0.4 for WordPress has XSS.medium6.1<2.0.42.0.4
CVE-2018-0585Cross-site scripting vulnerability in Ultimate Member plugin prior to version 2.0.4 for WordPress allows remote attackers to inject arbitrarmedium5.4<2.0.42.0.4
CVE-2022-1208The Ultimate Member plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Biography field featured on individual user prmedium6.4<=2.3.2–
CVE-2019-14947The ultimate-member plugin before 2.0.52 for WordPress has XSS during an account upgrade.medium5.4<2.0.522.0.52
CVE-2019-14945The ultimate-member plugin before 2.0.54 for WordPress has XSS.medium5.4<2.0.542.0.54
CVE-2019-10271An issue was discovered in the Ultimate Member plugin 2.39 for WordPress. It allows unauthorized profile and cover picture modification. It medium4.3<2.0.402.0.40
CVE-2019-14946The ultimate-member plugin before 2.0.52 for WordPress has XSS related to UM Roles create and edit operations.medium5.4<2.0.522.0.52
CVE-2022-1209The Ultimate Member plugin for WordPress is vulnerable to arbitrary redirects due to insufficient validation on supplied URLs in the social medium4.3<=2.3.1–
CVE-2018-10233The User Profile & Membership plugin before 2.0.7 for WordPress has no mitigations implemented against cross site request forgery attacks. Thigh8.8<2.0.72.0.7
CVE-2021-24306The Ultimate Member – User Profile, User Registration, Login & Membership Plugin WordPress plugin before 2.1.20 did not properly sanitise, vmedium5.4<2.1.202.1.20
CVE-2018-10234Authenticated Cross site Scripting exists in the User Profile & Membership plugin before 2.0.11 for WordPress via the "Account Deletion Custmedium4.8<2.0.112.0.11
CVE-2024-10528The Ultimate Member – User Profile, Registration, Login, Member Directory, Content Restriction & Membership Plugin plugin for WordPress is vmedium4.3<2.9.02.9.0
CVE-2025-0308The Ultimate Member – User Profile, Registration, Login, Member Directory, Content Restriction & Membership Plugin plugin for WordPress is vhigh7.5<2.9.22.9.2
CVE-2024-2765The Ultimate Member – User Profile, Registration, Login, Member Directory, Content Restriction & Membership Plugin plugin for WordPress is vmedium5.4<2.8.52.8.5
CVE-2024-8519The Ultimate Member – User Profile, Registration, Login, Member Directory, Content Restriction & Membership Plugin plugin for WordPress is vmedium6.4<2.8.72.8.7
CVE-2024-12276The Ultimate Member – User Profile, Registration, Login, Member Directory, Content Restriction & Membership Plugin plugin for WordPress is vmedium5.3<2.10.02.10.0
CVE-2025-0318The Ultimate Member – User Profile, Registration, Login, Member Directory, Content Restriction & Membership Plugin plugin for WordPress is vmedium5.3<2.9.22.9.2
CVE-2024-8520The Ultimate Member – User Profile, Registration, Login, Member Directory, Content Restriction & Membership Plugin plugin for WordPress is vmedium5.3<2.8.72.8.7

Am I affected?

Find out in one command. phpwarden checks your WordPress install against this advisory and 20,000+ others, ranked by real-world exploitation (CISA KEV + EPSS). Free, offline, open data.

# one-time install
pip install phpwarden

# then
phpwarden wordpress /var/www/html

Or keep it checked automatically with the GitHub Action or a nightly cron; see WordPress docs.

Install docs   How findings are ranked
A version is vulnerable when it falls inside an affected range and below the fixed version. phpwarden applies these ranges to the exact versions in your lockfile or install, so you only see what applies to you.