Is wp-hotel-booking (WordPress plugin) vulnerable?

WordPress wp-hotel-booking has 10 known advisories in the phpwarden feed. Feed 2026.10.29.1, updated 2026-10-28.

10advisories
3critical
0on CISA KEV
4no fix recorded
CVETitleSeverityCVSSAffectedFixed in
CVE-2023-5652The WP Hotel Booking WordPress plugin before 2.0.8 does not have authorisation and CSRF checks, as well as does not escape user input beforecritical9.8<2.0.82.0.8
CVE-2024-7855The WP Hotel Booking plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the update_review()high8.8<2.1.32.1.3
CVE-2020-29047The wp-hotel-booking plugin through 1.10.2 for WordPress allows remote attackers to execute arbitrary code because of an unserialize operaticritical9.8<=1.10.2–
CVE-2024-3605The WP Hotel Booking plugin for WordPress is vulnerable to SQL Injection via the 'room_type' parameter of the /wphb/v1/rooms/search-rooms REcritical10.0<=2.1.0–
CVE-2023-5799The WP Hotel Booking WordPress plugin before 2.0.8 does not have proper authorisation when deleting a package, allowing Contributor and abovmedium5.4<2.0.82.0.8
CVE-2021-36852Cross-Site Request Forgery (CSRF) vulnerability in ThimPress WP Hotel Booking plugin <= 1.10.5 at WordPress.medium4.3<=1.10.5–
CVE-2020-36757The WP Hotel Booking plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.10.1. This is due medium4.3<=1.10.1–
CVE-2024-13447The WP Hotel Booking plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the hotel_bookinmedium4.3<2.1.72.1.7
CVE-2024-12370The WP Hotel Booking plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check when adding rmedium5.3<2.1.62.1.6
CVE-2023-5651The WP Hotel Booking WordPress plugin before 2.0.8 does not have authorisation and CSRF checks, as well as does not ensure that the package medium5.4<2.0.82.0.8

Am I affected?

Find out in one command. phpwarden checks your WordPress install against this advisory and 20,000+ others, ranked by real-world exploitation (CISA KEV + EPSS). Free, offline, open data.

# one-time install
pip install phpwarden

# then
phpwarden wordpress /var/www/html

Or keep it checked automatically with the GitHub Action or a nightly cron; see WordPress docs.

Install docs   How findings are ranked
A version is vulnerable when it falls inside an affected range and below the fixed version. phpwarden applies these ranges to the exact versions in your lockfile or install, so you only see what applies to you.