Is wpforo (WordPress plugin) vulnerable?

WordPress wpforo has 16 known advisories in the phpwarden feed. Feed 2026.10.28.3, updated 2026-10-28.

16advisories
3critical
0on CISA KEV
10no fix recorded
CVETitleSeverityCVSSAffectedFixed in
CVE-2023-2249The wpForo Forum plugin for WordPress is vulnerable to Local File Include, Server-Side Request Forgery, and PHAR Deserialization in versionshigh8.8<=2.1.7–
CVE-2018-11709wpforo_get_request_uri in wpf-includes/functions.php in the wpForo Forum plugin before 1.4.12 for WordPress allows Unauthenticated Reflectedmedium6.1<1.4.121.4.12
CVE-2018-16613An issue was discovered in the update function in the wpForo Forum plugin before 1.5.2 for WordPress. A registered forum is able to escalatecritical9.8<1.5.21.5.2
CVE-2018-11515The wpForo plugin through 2018-02-05 for WordPress has SQL Injection via a search with the /forum/ wpfo parameter.critical9.8<1.4.51.4.5
CVE-2022-40200Auth. (subscriber+) Arbitrary File Upload vulnerability in wpForo Forum plugin <= 2.0.9 on WordPress.critical9.9<=2.0.9–
CVE-2019-19111The wpForo plugin 1.6.5 for WordPress allows XSS via the wp-admin/admin.php?page=wpforo-phrases langid parameter.medium6.1=1.6.5–
CVE-2019-19112The wpForo plugin 1.6.5 for WordPress allows XSS involving the wpf-dw-td-value class of dashboard.php.medium6.1=1.6.5–
CVE-2019-19109The wpForo plugin 1.6.5 for WordPress allows wp-admin/admin.php?page=wpforo-usergroups CSRF.high8.8=1.6.5–
CVE-2019-19110The wpForo plugin 1.6.5 for WordPress allows XSS via the wp-admin/admin.php?page=wpforo-phrases s parameter.medium4.8=1.6.5–
CVE-2022-40205Insecure direct object references (IDOR) vulnerability in the wpForo Forum plugin <= 2.0.5 on WordPress allows attackers with subscriber or medium5.4<=2.0.5–
CVE-2022-40206Insecure direct object references (IDOR) vulnerability in the wpForo Forum plugin <= 2.0.5 on WordPress allows attackers with subscriber or medium6.3<=2.0.5–
CVE-2022-38144Cross-Site Request Forgery (CSRF) vulnerability in gVectors Team wpForo Forum plugin <= 2.0.5 at WordPress.high8.8<=2.0.5–
CVE-2026-28562wpForo 2.4.14 contains an unauthenticated SQL injection vulnerability in Topics::get_topics() where the ORDER BY clause relies on ineffectivhigh8.2>=2.4.0 and <2.4.152.4.15
CVE-2025-0764The wpForo Forum plugin for WordPress is vulnerable to arbitrary file read due to insufficient input validation in the 'update' method of thmedium6.5<2.4.22.4.2
CVE-2026-28557wpForo Forum 2.4.14 contains a missing capability check vulnerability that allows authenticated users to trigger bulk wpForo usergroup reassmedium6.5>=2.4.0 and <2.4.162.4.16
CVE-2022-40632Cross-Site Request Forgery (CSRF) vulnerability in gVectors Team wpForo Forum plugin <= 2.0.5 on WordPress leading to topic deletion.medium5.4<=2.0.5–

Am I affected?

Find out in one command. phpwarden checks your WordPress install against this advisory and 20,000+ others, ranked by real-world exploitation (CISA KEV + EPSS). Free, offline, open data.

# one-time install
pip install phpwarden

# then
phpwarden wordpress /var/www/html

Or keep it checked automatically with the GitHub Action or a nightly cron; see WordPress docs.

Install docs   How findings are ranked
A version is vulnerable when it falls inside an affected range and below the fixed version. phpwarden applies these ranges to the exact versions in your lockfile or install, so you only see what applies to you.