CVE-2021-4445: The Premium Addons for Elementor plugin for WordPress is vulnerable to Arbitrary Option Updates in versions up to, and including, 4.5.1. This is due to missing capability and nonce checks in the pa_di

medium Affects premium-addons-for-elementor (WordPress plugin). Feed 2026.10.29.1, updated 2026-10-28; published ; advisory modified .

The Premium Addons for Elementor plugin for WordPress is vulnerable to Arbitrary Option Updates in versions up to, and including, 4.5.1. This is due to missing capability and nonce checks in the pa_di

Package
premium-addons-for-elementor (WordPress plugin) WordPress
Affected versions
<4.5.2
Fixed in
4.5.2
Severity
medium  CVSS 6.5
Exploitation
not on CISA KEV · EPSS 0% (36.1th percentile)
Published
2024-10-16
Source
nvd

References

CWE-862
NVD recordpremium-addons-for-elementor (WordPress plugin) advisories

Am I affected?

Find out in one command. phpwarden checks your WordPress install against this advisory and 20,000+ others, ranked by real-world exploitation (CISA KEV + EPSS). Free, offline, open data.

# one-time install
pip install phpwarden

# then
phpwarden wordpress /var/www/html

Or keep it checked automatically with the GitHub Action or a nightly cron; see WordPress docs.

Install docs   How findings are ranked

Related advisories