Is premium-addons-for-elementor (WordPress plugin) vulnerable?

WordPress premium-addons-for-elementor has 28 known advisories in the phpwarden feed. Feed 2026.10.29.1, updated 2026-10-28.

28advisories
0critical
0on CISA KEV
1no fix recorded
CVETitleSeverityCVSSAffectedFixed in
CVE-2025-14155The Premium Addons for Elementor – Powerful Elementor Templates & Widgets plugin for WordPress is vulnerable to unauthorized access of data medium5.3<4.11.544.11.54
CVE-2024-0376The Premium Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Wrapper Link Widget in amedium6.4<=4.10.16–
CVE-2024-0326The Premium Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Link Wrapper functionalimedium6.4<4.10.184.10.18
CVE-2021-24257The “Premium Addons for Elementor” WordPress Plugin before 4.2.8 has several widgets that are vulnerable to stored Cross-Site Scripting (XSSmedium5.4<4.2.84.2.8
CVE-2024-6434The Premium Addons for Elementor plugin for WordPress is vulnerable to Regular Expression Denial of Service (ReDoS) in all versions up to, alow3.1<4.10.364.10.36
CVE-2024-4203The Premium Addons Pro for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the maps widget in all versions umedium5.4<4.10.314.10.31
CVE-2024-2665The Premium Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's button in all versions umedium6.4<4.10.284.10.28
CVE-2024-2664The Premium Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Countdown Widget in all medium6.4<4.10.254.10.25
CVE-2024-2666The Premium Addons for Elementor plugin for WordPress is vulnerable to DOM-Based Stored Cross-Site Scripting via the plugin's Bullet List Wimedium5.4<4.10.254.10.25
CVE-2024-3647The Premium Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's post ticker widget in almedium6.4<4.10.294.10.29
CVE-2024-1680The Premium Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Image Settings URL of the Banner,medium6.4<4.10.224.10.22
CVE-2024-3885The Premium Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the subcontainer value parameter in amedium6.4<4.10.294.10.29
CVE-2021-4445The Premium Addons for Elementor plugin for WordPress is vulnerable to Arbitrary Option Updates in versions up to, and including, 4.5.1. Thimedium6.5<4.5.24.5.2
CVE-2024-8681The Premium Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Media Grid widget in allmedium6.4<4.10.534.10.53
CVE-2024-6824The Premium Addons for Elementor plugin for WordPress is vulnerable to unauthorized modification and loss of data due to a missing capabilitmedium4.3<4.10.394.10.39
CVE-2024-1242The Premium Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the button onclick attribute in all vmedium6.4<4.10.194.10.19
CVE-2024-2399The Premium Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's widgets in all versions medium6.4<4.10.244.10.24
CVE-2024-5553The Premium Addons for Elementor plugin for WordPress is vulnerable to DOM-Based Stored Cross-Site Scripting via several parameters in all vmedium4.4<4.10.344.10.34
CVE-2024-6340The Premium Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Countdown widget in all medium6.4<4.10.364.10.36
CVE-2024-4205The Premium Addons for Elementor plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the medium4.3<4.10.324.10.32
CVE-2024-4376The Premium Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Fancy Text widget in allmedium6.4<4.10.324.10.32
CVE-2024-4378The Premium Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's menu and shape widgets imedium6.4<4.10.324.10.32
CVE-2024-4379The Premium Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Global Tooltip widget inmedium5.4<4.10.324.10.32
CVE-2024-6495The Premium Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Animated Text widget in medium6.4<4.10.374.10.37
CVE-2024-10266The Premium Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Video Box widget in all medium6.4<4.10.614.10.61
CVE-2025-4774The Premium Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the data-countdown attribute of Countmedium6.4<4.11.94.11.9
CVE-2024-11937The Premium Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's linkURL in the Mobile Memedium6.4<4.10.704.10.70
CVE-2025-14163The Premium Addons for Elementor plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.11medium4.3<4.11.544.11.54

Am I affected?

Find out in one command. phpwarden checks your WordPress install against this advisory and 20,000+ others, ranked by real-world exploitation (CISA KEV + EPSS). Free, offline, open data.

# PHP projects (recommended)
composer require --dev phpwarden/phpwarden
# then
vendor/bin/phpwarden wordpress /var/www/html

# or, without Composer
pipx install phpwarden   &&   phpwarden wordpress /var/www/html

Or keep it checked automatically with the GitHub Action or a nightly cron; see WordPress docs.

Install docs   How findings are ranked
A version is vulnerable when it falls inside an affected range and below the fixed version. phpwarden applies these ranges to the exact versions in your lockfile or install, so you only see what applies to you.