PHP vulnerability advisories

Every CVE phpwarden knows about across the PHP engine, Composer packages and WordPress plugins, themes and core — ranked by real-world exploitation. Feed 2026.10.30.1, updated 2026-10-29. Browse by package.

19,305CVEs
8,640Composer advisories
12,328WordPress advisories
35Actively exploited (KEV) →
CVEPackageTitleSeverityCVSSEPSS
CVE-2014-5191ckeditor/ckeditorThe Preview plugin in CKEditor allows Cross-site scripting (XSS)medium0.02%
CVE-2022-1937awin-data-feed (WordPress plugin)The Awin Data Feed WordPress plugin before 1.8 does not sanitise and escape a parameter before outputting it back via an AJAX action (availamedium6.12%
CVE-2010-5098typo3/cms-frontendTYPO3 Cross-site scripting (XSS) vulnerability in the FORM content objectlow0.02%
CVE-2015-7562nilsteampassnet/teampassTeamPass vulnerable to Cross-site Scriptingmedium6.12%
CVE-2011-4278moodle/moodleMoodle XSS In Tag Autocomplete functionalitymedium0.02%
CVE-2011-4282moodle/moodleMoodle vulnerable to Cross-site Scriptinglow0.02%
CVE-2011-4286moodle/moodleMoodle vulnerable to Cross-site Scriptingmedium0.02%
CVE-2011-4306moodle/moodleMoodle XSS Vulnerabilitymedium0.02%
CVE-2014-3548moodle/moodleMoodle multiple cross-site scripting (XSS) vulnerabilitiesmedium0.02%
CVE-2014-9059moodle/moodleMoodle does not provide charset information in HTTP headersmedium0.02%
CVE-2018-20966woocommerce-jetpack (WordPress plugin)The woocommerce-jetpack plugin before 3.8.0 for WordPress has XSS in the Products Per Page feature.medium6.12%
CVE-2021-33557mantisbt/mantisbtMantisBT allows XSS in manage_custom_field_edit_page.phpmedium6.12%
CVE-2012-6147typo3/cmsTypo3 Backend API XSS Vulnerabilitylow0.02%
CVE-2010-5295WordPress coreCross-site scripting (XSS) vulnerability in wp-admin/plugins.php in WordPress before 3.0.2 might allow remote attackers to inject arbitrary medium4.32%
CVE-2010-1618apereo/phpcas, moodle/moodlephpCAS client library and Moodle Cross-site Scripting vulnerabilitymedium0.02%
CVE-2011-4955bsuite (WordPress plugin)Multiple cross-site scripting (XSS) vulnerabilities in ui_stats.php in the bSuite plugin before 5 alpha 3 for WordPress allow remote attackemedium6.12%
CVE-2022-0533ditty-news-ticker (WordPress plugin)The Ditty (formerly Ditty News Ticker) WordPress plugin before 3.0.15 is affected by a Reflected Cross-Site Scripting (XSS) vulnerability.medium6.12%
CVE-2018-10752tagregator (WordPress plugin)The Tagregator plugin 0.6 for WordPress has stored XSS via the title field in an Add New action.medium4.82%
CVE-2019-16218WordPress coreWordPress before 5.2.3 allows XSS in stored comments.medium6.12%
CVE-2013-6289apache-solr-for-typo3/solrApache Solr for TYPO3 (solr) extension is vulnerable to Cross-site scripting (XSS)medium4.32%
CVE-2015-9312newstatpress (WordPress plugin)The newstatpress plugin before 1.0.5 for WordPress has XSS related to an IMG element.medium6.12%
CVE-2016-4833nofollow-links (WordPress plugin)Cross-site scripting (XSS) vulnerability in the Nofollow Links plugin before 1.0.11 for WordPress allows remote attackers to inject arbitrarmedium6.12%
CVE-2010-2574mantisbt/mantisbtMantisBT Cross-site Scripting vulnerabilitylow0.02%
CVE-2021-24545wp-html-author-bio (WordPress plugin)The WP HTML Author Bio WordPress plugin through 1.2.0 does not sanitise the HTML allowed in the Bio of users, allowing them to use maliciousmedium5.42%
CVE-2022-0970getgrav/gravStored Cross-site Scripting in gravhigh7.12%
CVE-2011-4340symphonycms/symphony-2Symphony CMS vulnerable to Cross-site Scriptinglow0.02%
CVE-2019-11843mailpoet (WordPress plugin)The MailPoet plugin before 3.23.2 for WordPress allows remote attackers to inject arbitrary web script or HTML using extra parameters in themedium6.12%
CVE-2012-5888b13/seo_basicsBasic SEO Features (seo_basics) extension TYPO3 vulnerable to Cross-site Scriptinglow0.02%
CVE-2016-0770connections (WordPress plugin)Cross-site scripting (XSS) vulnerability in includes/admin/pages/manage.php in the Connections Business Directory plugin before 8.5.9 for Womedium6.12%
CVE-2022-1170jobmonster (WordPress plugin)In the Noo JobMonster WordPress theme before 4.5.2.9 JobMonster there is a XSS vulnerability as the input for the search form is provided thmedium6.12%
CVE-2015-7666payment-form-for-paypal-pro (WordPress plugin)Multiple cross-site scripting (XSS) vulnerabilities in the (1) cp_updateMessageItem and (2) cp_deleteMessageItem functions in cp_ppp_admin_imedium6.12%
CVE-2015-8834WordPress coreCross-site scripting (XSS) vulnerability in wp-includes/wp-db.php in WordPress before 4.2.2 allows remote attackers to inject arbitrary web medium6.12%
CVE-2018-12581phpmyadmin/phpmyadminphpMyAdmin XSS Vulnerabilitymedium6.12%
CVE-2017-9062WordPress coreIn WordPress before 4.7.5, there is improper handling of post meta data values in the XML-RPC API.high8.62%
CVE-2022-1946gallery (WordPress plugin)The Gallery WordPress plugin before 2.0.0 does not sanitise and escape a parameter before outputting it back in the response of an AJAX actimedium6.12%
CVE-2015-8766symphonycms/symphony-2Symphony CMS XSS Vulnerabilitiesmedium6.12%
CVE-2019-16221WordPress coreWordPress before 5.2.3 allows reflected XSS in the dashboard.medium6.12%
CVE-2015-3299floating-social-bar (WordPress plugin)Cross-site scripting (XSS) vulnerability in the Floating Social Bar plugin before 1.1.7 for WordPress allows remote attackers to inject arbimedium6.12%
CVE-2019-17672WordPress coreWordPress before 5.2.4 is vulnerable to a stored XSS attack to inject JavaScript into STYLE elements.medium6.12%
CVE-2013-5739WordPress coreThe default configuration of WordPress before 3.6.1 does not prevent uploads of .swf and .exe files, which might make it easier for remote alow3.52%
CVE-2022-0234woocs (WordPress plugin)The WOOCS WordPress plugin before 1.3.7.5 does not sanitise and escape the woocs_in_order_currency parameter of the woocs_get_products_pricemedium6.12%
CVE-2021-24229patreon-wordpress (WordPress plugin)The Jetpack Scan team identified a Reflected Cross-Site Scripting via the patreon_save_attachment_patreon_level AJAX action of the Patreon Wcritical9.62%
CVE-2017-18528pdf-print (WordPress plugin)The pdf-print plugin before 1.9.4 for WordPress has multiple XSS issues.medium6.12%
CVE-2017-5488WordPress coreMultiple cross-site scripting (XSS) vulnerabilities in wp-admin/update-core.php in WordPress before 4.7.1 allow remote attackers to inject amedium6.12%
CVE-2016-5731phpmyadmin/phpmyadminphpMyAdmin Cross-site scripting (XSS) vulnerabilitymedium6.12%
CVE-2017-7897mantisbt/mantisbtMantisBT XSS via my_view_page.php and view_user_page.phpmedium6.12%
CVE-2019-9553bolt/boltBolt Cross-site Scripting via the slug, teaser or title parametersmedium6.12%
CVE-2021-24233cooked (WordPress plugin)The Cooked Pro WordPress plugin before 1.7.5.6 was affected by unauthenticated reflected Cross-Site Scripting issues, due to improper sanitimedium6.12%
CVE-2014-3551moodle/moodleMoodle multiple cross-site scripting (XSS) vulnerabilitieslow0.02%
CVE-2012-6633WordPress coreCross-site scripting (XSS) vulnerability in wp-includes/default-filters.php in WordPress before 3.3.3 allows remote attackers to inject arbimedium4.32%
Page 13 of 146 · 7,262 advisories
Severity and CVSS come from the upstream advisory (OSV.dev, NVD, FriendsOfPHP); KEV marks CVEs on CISA's Known Exploited Vulnerabilities list; EPSS is FIRST's 30-day exploitation probability. Rows sort exploitation-first: KEV, then EPSS, then CVSS.