PHP vulnerability advisories

Every CVE phpwarden knows about across the PHP engine, Composer packages and WordPress plugins, themes and core — ranked by real-world exploitation. Feed 2026.10.30.2, updated 2026-10-30. Browse by package.

19,305CVEs
8,640Composer advisories
12,328WordPress advisories
35Actively exploited (KEV) →
CVEPackageTitleSeverityCVSSEPSS
CVE-2021-25040booking-calendar (WordPress plugin)The Booking Calendar WordPress plugin before 8.9.2 does not sanitise and escape the booking_type parameter before outputting it back in an amedium6.11%
CVE-2021-24290store-locator-plus (WordPress plugin)There are several endpoints in the Store Locator Plus for WordPress plugin through 5.5.15 that could allow unauthenticated attackers the abimedium6.11%
CVE-2021-20183moodle/moodleMoodle Vulnerable to Reflected Cross-site Scriptingmedium5.41%
CVE-2021-43808illuminate/view, laravel/frameworkLaravel Framework XSS in Blade templating enginemedium6.11%
CVE-2022-36020typo3/cms, typo3/cms-core, typo3/html-sanitizerTYPO3 HTML Sanitizer Bypasses Cross-Site Scripting Protectionmedium6.11%
CVE-2017-7298moodle/moodleMoodle Cross-site Scripting in the Course summary filter of the Add a new coursemedium5.41%
CVE-2023-2009pretty-url (WordPress plugin)Plugin does not sanitize and escape the URL field in the Pretty Url WordPress plugin through 1.5.4 settings, which could allow high-privilegmedium4.81%
CVE-2024-6753social-auto-poster (WordPress plugin)The Social Auto Poster plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘mapTypes’ parameter in the 'wpw_auto_postehigh7.21%
CVE-2022-3255pimcore/pimcorePimcore vulnerable to cross site scriptingmedium6.81%
CVE-2012-20001prestashop/prestashopPrestaShop XSS Vulnerabilitymedium6.11%
CVE-2021-24297goto (WordPress plugin)The Goto WordPress theme before 2.1 did not properly sanitize the formvalue JSON POST parameter in its tl_filter AJAX action, leading to an medium6.11%
CVE-2021-24925modern-events-calendar-lite (WordPress plugin)The Modern Events Calendar Lite WordPress plugin before 6.1.5 does not sanitise and escape the current_month_divider parameter of its mec_limedium6.11%
CVE-2021-24938woocommerce-currency-switcher (WordPress plugin)The WOOCS WordPress plugin before 1.3.7.1 does not sanitise and escape the key parameter of the woocs_update_profiles_data AJAX action (avaimedium6.11%
CVE-2021-24136testimonials-widget (WordPress plugin)Unvalidated input and lack of output encoding in the Testimonials Widget WordPress plugin, versions before 4.0.0, lead to multiple Cross-Sitmedium5.41%
CVE-2020-4061october/backendCross-site Scripting in Octoberlow3.71%
CVE-2021-39202WordPress coreWordPress is a free and open-source content management system written in PHP and paired with a MySQL or MariaDB database. In affected versiohigh7.61%
CVE-2018-18919wp-editor.md (WordPress plugin)The WP Editor.md plugin 10.0.1 for WordPress allows XSS via the comment area.medium4.81%
CVE-2022-25617code-snippets (WordPress plugin)Reflected Cross-Site Scripting (XSS) vulnerability in Code Snippets plugin <= 2.14.3 at WordPress via &orderby vulnerable parameter.medium4.71%
CVE-2021-34660wp-fusion-lite (WordPress plugin)The WP Fusion Lite WordPress plugin is vulnerable to Reflected Cross-Site Scripting via the startdate parameter found in the ~/includes/admimedium6.11%
CVE-2021-38359refer-a-friend-widget-for-wp (WordPress plugin)The WordPress InviteBox Plugin for viral Refer-a-Friend Promotions WordPress plugin is vulnerable to Reflected Cross-Site Scripting via the medium6.11%
CVE-2022-0946showdoc/showdocCross-site Scripting in ShowDocmedium5.41%
CVE-2012-4579phpmyadmin/phpmyadminphpMyAdmin Multiple XSS Vulnerabilitieslow0.01%
CVE-2019-17576dolibarr/dolibarrDolibarr Cross-site Scripting via outgoing email setup featuremedium5.41%
CVE-2019-17577dolibarr/dolibarrDolibarr Cross-site Scripting via outgoing email setup featuremedium5.41%
CVE-2019-17578dolibarr/dolibarrDolibarr Cross-site Scripting vulnerabilitymedium5.41%
CVE-2023-23921moodle/moodleMoodle Cross-site Scripting vulnerabilitymedium6.11%
CVE-2022-2092woocommerce-pdf-invoices\&-packing-slips (WordPress plugin)The WooCommerce PDF Invoices & Packing Slips WordPress plugin before 2.16.0 doesn't escape a parameter on its setting page, making it possibmedium6.11%
CVE-2022-35585forkcms/forkcmsForkCMS stored XSS via `start_date` parametermedium4.81%
CVE-2022-0253remdex/livehelperchatlivehelperchat is vulnerable to Cross-site Scriptingmedium5.41%
CVE-2022-0737text-hover (WordPress plugin)The Text Hover WordPress plugin before 4.2 does not sanitize and escape the text to hover, which could allow high privilege users to performmedium4.81%
CVE-2017-16880filp/whoopsfilp whoops Cross-site Scripting vulnerabilitymedium6.11%
CVE-2018-8071mautic/coreXSS vulnerability in theme config file in Mauticmedium6.11%
CVE-2023-0377scriptless-social-sharing (WordPress plugin)The Scriptless Social Sharing WordPress plugin before 3.2.2 does not validate and escape some of its block options before outputting them bamedium5.41%
CVE-2020-14475dolibarr/dolibarrDolibarr reflected cross-site scripting (XSS) vulnerabilitymedium6.11%
CVE-2021-24923newsletter\,-smtp\,-email-marketing-and-subscribe (WordPress plugin)The Newsletter, SMTP, Email marketing and Subscribe forms by Sendinblue WordPress plugin before 3.1.25 does not escape the sib-statistics-damedium6.11%
CVE-2021-25024eventcalendar (WordPress plugin)The EventCalendar WordPress plugin before 1.1.51 does not escape some user input before outputting it back in attributes, leading to Reflectmedium6.11%
CVE-2021-4222wp-paginate (WordPress plugin)The WP-Paginate WordPress plugin before 2.1.4 does not sanitise and escape its preset settings, allowing high privilege users such as admin medium4.81%
CVE-2022-0945showdoc/showdocStored Cross-site Scripting in ShowDocmedium5.41%
CVE-2021-33563phanan/koelImproper rate limiting in Koelhigh0.01%
CVE-2021-4107yetiforce/yetiforce-crmyetiforcecrm is vulnerable to Cross-site Scriptingmedium5.31%
CVE-2021-41258getkirby/cmsCross-site scripting (XSS) from image block content in the site frontendmedium5.41%
CVE-2023-7246system-dashboard (WordPress plugin)The System Dashboard WordPress plugin before 2.8.10 does not sanitize and escape some parameters, which could allow administrators in multismedium5.41%
CVE-2020-27850wp-premium/gravityformsGravity Forms stored Cross-Site Scripting (XSS) vulnerabilitymedium4.81%
CVE-2022-3392wp-humans.txt (WordPress plugin)The WP Humans.txt WordPress plugin through 1.0.6 does not sanitise and escape some of its settings, which could allow high privilege users smedium4.81%
CVE-2017-6213paypal/invoice-sdk-phppaypal/invoice-sdk-php reflected XSSmedium5.41%
CVE-2017-6215paypal/permissions-sdk-phppaypal/permissions-sdk-php reflected Cross-site Scripting (XSS)medium5.41%
CVE-2018-5362wpglobus (WordPress plugin), wpglobus/wpglobusThe WPGlobus plugin 1.9.6 for WordPress has XSS via the wpglobus_option[post_type][page] parameter to wp-admin/options.php.medium4.81%
CVE-2018-5364wpglobus (WordPress plugin), wpglobus/wpglobusThe WPGlobus plugin 1.9.6 for WordPress has XSS via the wpglobus_option[browser_redirect][redirect_by_language] parameter to wp-admin/optionmedium4.81%
CVE-2018-5367wpglobus (WordPress plugin), wpglobus/wpglobusThe WPGlobus plugin 1.9.6 for WordPress has XSS via the wpglobus_option[post_type][post] parameter to wp-admin/options.php.medium4.81%
CVE-2021-24883popup-anything (WordPress plugin)The Popup Anything WordPress plugin before 2.0.4 does not escape the Link Text and Button Text fields of Popup, which could allow users withmedium5.41%
Page 42 of 146 · 7,262 advisories
Severity and CVSS come from the upstream advisory (OSV.dev, NVD, FriendsOfPHP); KEV marks CVEs on CISA's Known Exploited Vulnerabilities list; EPSS is FIRST's 30-day exploitation probability. Rows sort exploitation-first: KEV, then EPSS, then CVSS.