PHP vulnerability advisories

Every CVE phpwarden knows about across the PHP engine, Composer packages and WordPress plugins, themes and core — ranked by real-world exploitation. Feed 2026.10.31.2, updated 2026-10-31. Browse by package.

19,312CVEs
8,647Composer advisories
12,328WordPress advisories
35Actively exploited (KEV) →
CVEPackageTitleSeverityCVSSEPSS
CVE-2007-6677random-anti-spam-image (WordPress plugin)Cross-site scripting (XSS) vulnerability in Peter's Random Anti-Spam Image 0.2.4 and earlier plugin for WordPress allows remote attackers tomedium4.31%
CVE-2021-4080bytefury/cratercrater is vulnerable to Unrestricted Upload of File with Dangerous Typehigh8.81%
CVE-2006-5734phpmailer/phpmailerPHPMailer Local file inclusionmedium0.01%
CVE-2021-25119automatic-grid-image-listing (WordPress plugin)The AGIL WordPress plugin through 1.0 accepts all zip files and automatically extracts the zip file without validating the extracted file tyhigh7.21%
CVE-2022-1273import-wp (WordPress plugin)The Import WP WordPress plugin before 2.4.6 does not validate the imported file in some cases, allowing high privilege users such as admin thigh7.21%
CVE-2022-1409hotel-booking-engine-\&-pms (WordPress plugin)The VikBooking Hotel Booking Engine & PMS WordPress plugin before 1.5.8 does not properly validate images, allowing high privilege users suchigh7.21%
CVE-2024-27516remdex/livehelperchatlivehelperchat Server-Side Template Injectionmedium0.01%
CVE-2024-10793wp-security-audit-log (WordPress plugin)The WP Activity Log plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the user_id parameter in all versions up to, and ihigh7.21%
CVE-2022-45152moodle/moodleMoodle blind Server-Side Request Forgery (SSRF) vulnerability in LTI provider librarycritical9.11%
CVE-2021-24198wpdatatables (WordPress plugin)The wpDataTables – Tables & Table Charts premium WordPress plugin before 3.4.2 has Improper Access Control. A low privilege authenticated ushigh8.11%
CVE-2019-11807woocommerce-checkout-manager (WordPress plugin)The WooCommerce Checkout Manager plugin before 4.3 for WordPress allows media deletion via the wp-admin/admin-ajax.php?action=update_attachmhigh7.51%
CVE-2020-7994dolibarr/dolibarrDolibarr cross-site scripting (XSS) vulnerabilitymedium6.11%
CVE-2019-10905erusev/parsedownParsedown Class-Name Injectionhigh8.11%
CVE-2019-17231onetone (WordPress theme)includes/theme-functions.php in the OneTone theme through 3.0.6 for WordPress has multiple stored XSS issues.medium6.11%
CVE-2017-10844baserproject/basercmsCode Injection in baserCMShigh8.81%
CVE-2022-0383wp-review-slider (WordPress plugin)The WP Review Slider WordPress plugin before 11.0 does not sanitise and escape the pid parameter when copying a Twitter source, which could high7.21%
CVE-2022-23911ap-custom-testimonial (WordPress plugin)The Testimonial WordPress Plugin WordPress plugin before 1.4.7 does not validate and escape the id parameter before using it in a SQL statemhigh7.21%
CVE-2022-0362showdoc/showdocSQL Injection in showdocmedium6.71%
CVE-2016-9856phpmyadmin/phpmyadminphpMyAdmin XSS Vulnerabilitymedium6.11%
CVE-2016-9857phpmyadmin/phpmyadminphpMyAdmin XSS Vulnerabilitymedium6.11%
CVE-2017-18012z-url-preview (WordPress plugin)The Z-URL Preview plugin 1.6.1 for WordPress has XSS via the class.zlinkpreview.php url parameter.medium6.11%
CVE-2019-15818simple-301-redirects-addon-bulk-uploader (WordPress plugin)The simple-301-redirects-addon-bulk-uploader plugin through 1.2.4 for WordPress has no requirement for authentication for action=bulk301expomedium6.11%
CVE-2019-15820login-or-logout-menu-item (WordPress plugin)The login-or-logout-menu-item plugin before 1.2.0 for WordPress has no requirement for lolmi_save_settings authentication.medium6.11%
CVE-2020-15721francoisjacquet/rosariosisCross-site Scripting in RosarioSISmedium6.11%
CVE-2015-1874contact-form-7-to-database-extension (WordPress plugin)Cross-site request forgery (CSRF) vulnerability in the Contact Form DB (aka CFDB and contact-form-7-to-database-extension) plugin before 2.8medium6.81%
CVE-2023-5070ultimate-social-media-icons (WordPress plugin)The Social Media Share Buttons & Social Sharing Icons plugin for WordPress is vulnerable to Sensitive Information Exposure in versions up tomedium6.51%
CVE-2015-3274moodle/moodleMoodle cross-site scripting (XSS) vulnerabilitymedium6.11%
CVE-2015-3275moodle/moodleMoodle multiple cross-site scripting (XSS) vulnerabilitiesmedium6.11%
CVE-2016-2152moodle/moodleMoodle XSS from profile fields from external dbmedium6.11%
CVE-2016-2153moodle/moodleMoodle Reflected XSS in mod_data advanced searchmedium6.11%
CVE-2024-11635wordpress-file-upload (WordPress plugin)The WordPress File Upload plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.24.12 via the critical9.81%
CVE-2020-24063canto (WordPress plugin)The Canto plugin 1.3.0 for WordPress allows includes/lib/download.php?subdomain= SSRF.high7.21%
CVE-2026-34036dolibarr/dolibarrDolibarr Core Discloses Sensitive Data via Authenticated Local File Inclusion in selectobject.phpmedium6.51%
CVE-2023-39062spipu/html2pdfSpipu HTML2PDF vulnerable to cross-site scriptingmedium6.11%
CVE-2023-50262dompdf/dompdfDenial of service caused by infinite recursion when parsing SVG imagesmedium5.31%
CVE-2019-11512contao/contao, contao/core-bundleContao SQL injection in the file managercritical9.81%
CVE-2022-0687amelia (WordPress plugin)The Amelia WordPress plugin before 1.0.47 stores image blobs into actual files whose extension is controlled by the user, which may lead to high8.81%
CVE-2022-24800october/systemOctober CMS upload process vulnerable to RCE via Race Conditionhigh8.11%
CVE-2023-4402essential-blocks (WordPress plugin), essential-blocks-pro (WordPress plugin)The Essential Blocks plugin for WordPress is vulnerable to PHP Object Injection in versions up to, and including, 4.2.0 via deserialization high8.11%
CVE-2022-2261wpide (WordPress plugin)The WPIDE WordPress plugin before 3.0 does not sanitize and validate the filename parameter before using it in a require statement in the adhigh7.21%
CVE-2025-7360ht-contactform (WordPress plugin)The HT Contact Form Widget For Elementor Page Builder & Gutenberg Blocks & Form Builder plugin for WordPress is vulnerable to arbitrary filecritical9.11%
CVE-2020-36655yiisoft/yii2-giiCommand injection in yiisoft/yii2-giihigh8.81%
CVE-2021-32717shopware/core, shopware/platformPrivate files publicly accessible with Cloud Storage providershigh7.51%
CVE-2026-6826concrete5/concrete5Concrete CMS is vulnerable to unauthenticated file usage disclosuremedium0.01%
CVE-2019-12204silverstripe/cms, silverstripe/frameworkMissing warning can lead to unauthenticated admin access in SilverStripecritical9.81%
CVE-2022-2357wsm-downloader (WordPress plugin)The WSM Downloader WordPress plugin through 1.4.0 allows any visitor to use its remote file download feature to download any local files, inhigh7.51%
CVE-2024-9224hello-world (WordPress plugin)The Hello World plugin for WordPress is vulnerable to Arbitrary File Reading in all versions up to, and including, 2.1.1 via the hello_worldmedium6.51%
CVE-2017-14313shibboleth (WordPress plugin)The shibboleth_login_form function in shibboleth.php in the Shibboleth plugin before 1.8 for WordPress is prone to an XSS vulnerability due medium6.11%
CVE-2024-10828woo-order-export-lite (WordPress plugin)The Advanced Order Export For WooCommerce plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 3high8.11%
CVE-2022-23043tribalsystems/zenarioFile upload restriction bypass in Zenario CMShigh7.21%
Page 74 of 387 · 19,312 advisories
Severity and CVSS come from the upstream advisory (OSV.dev, NVD, FriendsOfPHP); KEV marks CVEs on CISA's Known Exploited Vulnerabilities list; EPSS is FIRST's 30-day exploitation probability. Rows sort exploitation-first: KEV, then EPSS, then CVSS.