PHP vulnerability advisories

Every CVE phpwarden knows about across the PHP engine, Composer packages and WordPress plugins, themes and core — ranked by real-world exploitation. Feed 2026.10.31.2, updated 2026-10-31. Browse by package.

19,312CVEs
8,647Composer advisories
12,328WordPress advisories
35Actively exploited (KEV) →
CVEPackageTitleSeverityCVSSEPSS
CVE-2017-12872simplesamlphp/simplesamlphpSimpleSAMLphp allows timing side-channel attacksmedium5.91%
CVE-2023-6700wp-gdpr-compliance (WordPress plugin)The Cookie Information | Free GDPR Consent Solution plugin for WordPress is vulnerable to arbitrary option updates due to a missing capabilihigh8.81%
CVE-2024-9772uix-shortcodes (WordPress plugin)The The Uix Shortcodes – Compatible with Gutenberg plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up tohigh7.31%
CVE-2017-18015share-this-image (WordPress plugin)The ILLID Share This Image plugin before 1.04 for WordPress has XSS via the sharer.php url parameter.medium6.11%
CVE-2017-18487adsense-plugin (WordPress plugin)The adsense-plugin (aka Google AdSense) plugin before 1.44 for WordPress has multiple XSS issues.medium6.11%
CVE-2017-18490contact-form-multi (WordPress plugin)The contact-form-multi plugin before 1.2.1 for WordPress has multiple XSS issues.medium6.11%
CVE-2017-18491contact-form-plugin (WordPress plugin)The contact-form-plugin plugin before 4.0.6 for WordPress has multiple XSS issues.medium6.11%
CVE-2017-18492contact-form-to-db (WordPress plugin)The contact-form-to-db plugin before 1.5.7 for WordPress has multiple XSS issues.medium6.11%
CVE-2013-4997phpmyadmin/phpmyadminphpMyAdmin Multiple cross-site scripting (XSS) vulnerabilitiesmedium0.01%
CVE-2017-9840dolibarr/dolibarrDolibarr ERP and CRM Unsafe File Upload Vulnerabilityhigh8.81%
CVE-2021-24125contact-form-submissions (WordPress plugin)Unvalidated input in the Contact Form Submissions WordPress plugin before 1.7.1, could lead to SQL injection in the wpcf7_contact_form GET phigh7.21%
CVE-2022-25811transposh-wordpress-translation (WordPress plugin)The Transposh WordPress Translation WordPress plugin through 1.0.8 does not sanitise and escape the order and orderby parameters before usinhigh7.21%
CVE-2022-0257pimcore/pimcorepimcore is vulnerable to Cross-site Scriptingmedium5.41%
CVE-2022-0285pimcore/pimcoreCross-site Scripting in pimcoremedium5.41%
CVE-2023-51450baserproject/basercmsbaserCMS OS command injection vulnerability in Installermedium5.61%
CVE-2014-7830moodle/moodleMoodle cross-site scripting (XSS) vulnerabilitylow0.01%
CVE-2023-3186popup (WordPress plugin)The Popup by Supsystic WordPress plugin before 1.10.19 has a prototype pollution vulnerability that could allow an attacker to inject arbitrcritical9.81%
CVE-2019-7859magento/community-edition, magento/product-community-editionMagento 2 Community Edition Path Traversal Vulnerabilityhigh7.51%
CVE-2022-0920salon-booking-system (WordPress plugin)The Salon booking system Free and Pro WordPress plugins before 7.6.3 do not have proper authorisation in some of its endpoints, which could high7.51%
CVE-2018-1043moodle/moodleMoodle Setting for blocked hosts list can be bypassed with multiple A record hostnamesmedium6.51%
CVE-2018-0546wp-all-import (WordPress plugin)Cross-site scripting vulnerability in WP All Import plugin prior to version 3.4.6 for WordPress allows an attacker to inject arbitrary web smedium6.11%
CVE-2018-0547wp-all-import (WordPress plugin)Cross-site scripting vulnerability in WP All Import plugin prior to version 3.4.7 for WordPress allows an attacker to inject arbitrary web smedium6.11%
CVE-2022-28666custom-product-tabs-for-woocommerce (WordPress plugin)Broken Access Control vulnerability in YIKES Inc. Custom Product Tabs for WooCommerce plugin <= 1.7.7 at WordPress leading to &yikes-the-conmedium5.31%
CVE-2018-12534quick-chat (WordPress plugin)A SQL injection issue was discovered in the Quick Chat plugin before 4.00 for WordPress.critical9.81%
CVE-2019-19848typo3/cms, typo3/cms-coreTYPO3 Directory Traversal on ZIP extractionmedium6.81%
CVE-2019-15570bedita/beditaBEdita vulnerable to SQL injectioncritical9.81%
CVE-2022-1412log-wp-mail (WordPress plugin)The Log WP_Mail WordPress plugin through 0.1 saves sent email in a publicly accessible directory using predictable filenames, allowing any uhigh7.51%
CVE-2022-2536transposh-translation-filter-for-wordpress (WordPress plugin)The Transposh WordPress Translation plugin for WordPress is vulnerable to unauthorized setting changes by unauthenticated users in versions medium5.31%
CVE-2018-7644simplesamlphp/saml2SimpleSAMLphp Improper Verification of Cryptographic Signaturehigh7.51%
CVE-2014-9310wordpress-backup-to-dropbox (WordPress plugin)Cross-site scripting (XSS) vulnerability in the WordPress Backup to Dropbox plugin before 4.1 for WordPress.medium6.11%
CVE-2013-1833moodle/moodleMoodle Multiple cross-site scripting (XSS) vulnerabilities in the File Picker modulelow0.01%
CVE-2022-1939allow-svg-files (WordPress plugin)The Allow svg files WordPress plugin before 1.1 does not properly validate uploaded files, which could allow high privilege users such as adhigh7.21%
CVE-2011-3591phpmyadmin/phpmyadminphpMyAdmin Multiple XSS Vulnerabilities After Inline Editing and Savelow0.01%
CVE-2011-3592phpmyadmin/phpmyadminphpMyAdmin Multiple XSS Vulnerabilitieslow0.01%
CVE-2012-4345phpmyadmin/phpmyadminphpMyAdmin Multiple Cross-site Scripting Vulnerabilities in the Database Structure pagelow0.01%
CVE-2012-5339phpmyadmin/phpmyadminphpMyAdmin multiple cross-site scripting vulnerabilitieslow0.01%
CVE-2014-3943typo3/cmsTypo3 XSS Vulnerabilitieslow0.01%
CVE-2015-0212moodle/moodleMoodle cross-site scripting (XSS) vulnerabilitylow0.01%
CVE-2015-0216moodle/moodleMoodle does not set the RISK_XSS bit for graderslow0.01%
CVE-2015-2273moodle/moodleMoodle cross-site scripting (XSS) vulnerabilitylow0.01%
CVE-2015-3174moodle/moodleMoodle does not set the RISK_XSS bit for graderslow0.01%
CVE-2015-3178moodle/moodleMoodle cross-site scripting (XSS) vulnerabilitylow0.01%
CVE-2022-2903ninja-forms (WordPress plugin)The Ninja Forms Contact Form WordPress plugin before 3.6.13 unserialises the content of an imported file, which could lead to PHP object injhigh7.21%
CVE-2022-0206newstatpress (WordPress plugin)The NewStatPress WordPress plugin before 1.3.6 does not properly escape the whatX parameters before outputting them back in attributes, leadmedium6.11%
CVE-2013-4751symfony/symfony, symfony/validatorSymfony collectionCascaded and collectionCascadedDeeply fields security bypasshigh8.11%
CVE-2022-37333exceedone/exment, exceedone/laravel-adminexceedone/exment and exceedone/laravel-admin SQL Injection vulnerabilityhigh8.81%
CVE-2021-24131anti-spam (WordPress plugin)Unvalidated input in the Anti-Spam by CleanTalk WordPress plugin, versions before 5.149, lead to multiple authenticated SQL injection vulnerhigh7.21%
CVE-2021-25104ocean-extra (WordPress plugin)The Ocean Extra WordPress plugin before 1.9.5 does not escape generated links which are then used when the OceanWP is active, leading to a Rmedium6.11%
CVE-2022-0440catch-themes-demo-import (WordPress plugin)The Catch Themes Demo Import WordPress plugin before 2.1.1 does not validate one of the file to be imported, which could allow high privivilhigh7.21%
CVE-2022-0593login-with-phone-number (WordPress plugin)The Login with phone number WordPress plugin before 1.3.7 includes a file delete.php with no form of authentication or authorization checks medium6.51%
Page 75 of 387 · 19,312 advisories
Severity and CVSS come from the upstream advisory (OSV.dev, NVD, FriendsOfPHP); KEV marks CVEs on CISA's Known Exploited Vulnerabilities list; EPSS is FIRST's 30-day exploitation probability. Rows sort exploitation-first: KEV, then EPSS, then CVSS.