PHP vulnerability advisories

Every CVE phpwarden knows about across the PHP engine, Composer packages and WordPress plugins, themes and core — ranked by real-world exploitation. Feed 2026.10.29.4, updated 2026-10-29. Browse by package.

19,303CVEs
8,638Composer advisories
12,328WordPress advisories
35Actively exploited (KEV) →
CVEPackageTitleSeverityCVSSEPSS
CVE-2018-19370wordpress-seo (WordPress plugin)A Race condition vulnerability in unzip_file in admin/import/class-import-settings.php in the Yoast SEO (wordpress-seo) plugin before 9.2.0 medium6.63%
CVE-2024-7627file-manager (WordPress plugin)The Bit File Manager plugin for WordPress is vulnerable to Remote Code Execution in versions 6.0 to 6.5.5 via the 'checkSyntax' function. Thhigh8.13%
CVE-2022-24800october/systemOctober CMS upload process vulnerable to RCE via Race Conditionhigh8.11%
CVE-2021-24377autoptimize (WordPress plugin)The Autoptimize WordPress plugin before 2.7.8 attempts to remove potential malicious files from the extracted archive uploaded via the 'Impohigh8.11%
CVE-2019-8232magento/community-editionMagento 2 Community Edition RCE Vulnerabilitymedium6.61%
CVE-2022-0279anycomment (WordPress plugin)The AnyComment WordPress plugin before 0.2.18 is affected by a race condition when liking/disliking a comment/reply, which could allow any alow3.10%
CVE-2022-36422wp-postratings (WordPress plugin)Rating increase/decrease via race condition in Lester 'GaMerZ' Chan WP-PostRatings plugin <= 1.89 at WordPress.medium4.30%
CVE-2022-40310rate-my-post (WordPress plugin)Authenticated (subscriber+) Race Condition vulnerability in Rate my Post – WP Rating System plugin <= 3.3.4 at WordPress allows attackers tomedium4.30%
CVE-2022-48366ezsystems/ezplatform-kernel, ezsystems/ezpublish-kernelTiming attack in eZ Platform Ibexalow3.70%
CVE-2022-40130wp-polls (WordPress plugin)Auth. (subscriber+) Race Condition vulnerability in WP-Polls plugin <= 2.76.0 on WordPress.medium4.30%
CVE-2023-4642kk-star-ratings (WordPress plugin)The kk Star Ratings WordPress plugin before 5.4.6 does not implement atomic operations, allowing one user vote multiple times on a poll due medium5.90%
CVE-2025-7954shopware/platformShopware race condition bypasses voucher restrictionsmedium0.00%
CVE-2023-6109yop-poll (WordPress plugin)The YOP Poll plugin for WordPress is vulnerable to a race condition in all versions up to, and including, 6.5.26. This is due to improper remedium5.30%
CVE-2023-2010forminator (WordPress plugin)The Forminator WordPress plugin before 1.24.1 does not use an atomic operation to check whether a user has already voted, and then update thlow3.10%
CVE-2026-71537paymenter/paymenterPaymenter has a credit-refund double-spend race condition in service downgrade (doUpgrade)medium6.50%
CVE-2026-48505filament/filamentFilament: Multi-factor authentication (app) recovery codes can still be used multiple times via concurrent submissionhigh7.40%
CVE-2025-69198pterodactyl/panelPterodactyl improperly locks resources allowing raced queries to create more resources than allotedmedium6.50%
CVE-2026-47741shopper/cartshopper/framework: Race condition on Discount.usage_limit allows silent over-redemptionmedium5.90%
CVE-2026-34368wwbn/avideoAVideo Vulnerable to Wallet Balance Double-Spend via TOCTOU Race Condition in transferBalancemedium5.30%
CVE-2026-55219paymenter/paymenterPaymenter has race condition in payWithCredit() that enables credit double-spendmedium5.30%
CVE-2026-31824sylius/syliusSylius has a Promotion Usage Limit Bypass via Race Conditionhigh8.20%
Page 1 of 1 · 21 advisories
Severity and CVSS come from the upstream advisory (OSV.dev, NVD, FriendsOfPHP); KEV marks CVEs on CISA's Known Exploited Vulnerabilities list; EPSS is FIRST's 30-day exploitation probability. Rows sort exploitation-first: KEV, then EPSS, then CVSS.