PHP vulnerability advisories

Every CVE phpwarden knows about across the PHP engine, Composer packages and WordPress plugins, themes and core — ranked by real-world exploitation. Feed 2026.10.29.1, updated 2026-10-28. Browse by package.

19,303CVEs
8,638Composer advisories
12,328WordPress advisories
35Actively exploited (KEV) →
CVEPackageTitleSeverityCVSSEPSS
CVE-2016-10033 KEVphpmailer/phpmailerRemote code execution via crafted Sender in the isMail transportcritical9.8100%
CVE-2022-39986billz/raspap-webguiRaspAP Command Injection vulnerabilitycritical9.899%
CVE-2016-10045phpmailer/phpmailerRemote code execution in PHPMailercritical9.898%
CVE-2023-0315froxlor/froxlorFroxlor vulnerable to Command Injectionhigh8.898%
CVE-2016-10074swiftmailer/swiftmailerSwift Mailer mail transport Command Injectioncritical9.844%
CVE-2016-10034zendframework/zend-mailzend-mail remote code execution via Sendmail adaptercritical9.838%
CVE-2022-39987billz/raspap-webguiRaspAP Command Injection vulnerabilityhigh8.837%
CVE-2022-26265contao/managed-editionRemote Code Execution in Contao Managed Editioncritical9.830%
CVE-2021-38556billz/raspap-webguiCommand Injection in RaspAP 2.6.6high8.813%
CVE-2015-5161zendframework/zendframework, zendframework/zendframework1, zendframework/zendxmlZendXml and Zend Framework contain XXE and XEE Vulnerabilitiesmedium0.010%
CVE-2014-1905videowhisper-live-streaming-integration (WordPress plugin)Unrestricted file upload vulnerability in ls/vw_snapshots.php in the VideoWhisper Live Streaming Integration plugin before 4.29.5 for WordPrhigh10.010%
CVE-2023-6634learnpress (WordPress plugin)The LearnPress plugin for WordPress is vulnerable to Command Injection in all versions up to, and including, 4.2.5.7 via the get_content funhigh8.19%
CVE-2015-1561centreon/centreonCentreon Command Injectionhigh8.58%
CVE-2020-35136dolibarr/dolibarrDolibarr authenticated Remote Code Executionhigh7.27%
CVE-2023-32073wwbn/avideoWWBN AVideo command injection vulnerabilityhigh8.86%
CVE-2015-7806form-manager (WordPress plugin)Eval injection vulnerability in the fm_saveHelperGatherItems function in ajax.php in the Form Manager plugin before 1.7.3 for WordPress allocritical9.86%
CVE-2022-25866czproject/git-phpCommand injection in czproject/git-phphigh8.14%
CVE-2014-5014wordpress-flash-uploader (WordPress plugin)The WordPress Flash Uploader plugin before 3.1.3 for WordPress allows remote attackers to execute arbitrary commands via vectors related to critical9.84%
CVE-2014-3114ezpz-one-click-backup (WordPress plugin)The EZPZ One Click Backup (ezpz-one-click-backup) plugin 12.03.10 and earlier for WordPress allows remote attackers to execute arbitrary comcritical9.83%
CVE-2024-35242composer/composerComposer has multiple command injections via malicious git/hg branch nameshigh8.83%
CVE-2020-13664drupal/core, drupal/drupalDrupal 8 and 9 have a remote code execution vulnerability under certain circumstances. An attacker could trick an adminhigh8.83%
CVE-2021-36024magento/community-edition, magento/project-community-editionMagento is affected by an os command injection via the Data collection endpointhigh7.23%
CVE-2021-41116composer/composerImproper escaping of command arguments on Windows leading to command injectionhigh8.23%
CVE-2015-4336xcloner (WordPress plugin)cloner.functions.php in the XCloner plugin 3.1.2 for WordPress allows remote authenticated users to execute arbitrary commands via a file comedium6.53%
CVE-2012-6531zendframework/zendframework1Zend Framework XEE Vulnerabilitymedium0.03%
CVE-2023-30260billz/raspap-webguiRaspAP raspap-webgui Command Injection vulnerabilityhigh8.82%
CVE-2021-37708shopware/core, shopware/platformCommand injection in mail agent settingshigh8.82%
CVE-2014-2683zendframework/zendframework1, zendframework/zendopenid, zendframework/zendrest +7 moreSeveral Zend Products Vulnerable to XXE and XEE attacksmedium0.02%
CVE-2016-6609phpmyadmin/phpmyadminphpMyAdmin PHP code injectionhigh8.82%
CVE-2026-41304wwbn/avideoWWBN AVideo: RCE cause by clonesite plugincritical9.82%
CVE-2014-2682zendframework/zendframework1, zendframework/zendopenid, zendframework/zendrest +7 moreSeveral Zend Products Vulnerable to XXE and XEE attacksmedium0.02%
CVE-2024-22188typo3/cms-coreTYPO3 Install Tool vulnerable to Code Executionhigh7.22%
CVE-2021-41800mediawiki/coreMediaWiki allows a denial of servicemedium5.32%
CVE-2012-6532zendframework/zendframework1Zend Framework XEE Vulnerabilitymedium0.02%
CVE-2023-1877microweber/microweberMicroweber vulnerable to command injectionmedium6.12%
CVE-2016-10762camptix (WordPress plugin)The CampTix Event Ticketing plugin before 1.5 for WordPress allows CSV injection when the export tool is used.high7.52%
CVE-2026-53932wnx/laravel-backup-restorelaravel-backup-restore has an OS Command Injection during database restorehigh8.02%
CVE-2023-0789thorsten/phpmyfaqCommand Injection in thorsten/phpmyfaqcritical9.82%
CVE-2022-36104typo3/cms, typo3/cms-coreTYPO3 CMS vulnerable to Denial of Service in Page Error Handlingmedium5.92%
CVE-2026-55182librenms/librenmsLibreNMS Vulnerable to Remote Code Execution by Signal Alert Transportation modulehigh0.02%
CVE-2021-20185moodle/moodleMoodle Client side denial of service via personal messagemedium5.31%
CVE-2023-3566wallabag/wallabagWallabag vulnerable to Allocation of Resources Without Limits or Throttlingmedium6.51%
CVE-2021-39217openmage/magento-ltsFix for arbitrary command execution in custom layout update through blockshigh7.21%
CVE-2020-12697directmailteam/direct-mailDenial of service in direct_mailmedium5.31%
CVE-2021-41143openmage/magento-ltsFix for arbitrary file deletion in customer media allows for remote code executionhigh7.21%
CVE-2023-6999pods (WordPress plugin)The Pods – Custom Content Types and Fields plugin for WordPress is vulnerable to Remote Code Exxecution via shortcode in all versions up to,high8.81%
CVE-2021-41231openmage/magento-ltsDataFlow upload remote code execution vulnerabilityhigh7.21%
CVE-2023-38492getkirby/cmsDenial of service from unlimited password lengthsmedium5.31%
CVE-2021-41144openmage/magento-ltsFix for authenticated remote code execution through layout updatehigh8.81%
CVE-2022-43686concrete5/concrete5Concrete CMS vulnerable to Uncontrolled Resource Consumption leading to DoSmedium6.51%
Page 1 of 3 · 116 advisories
Severity and CVSS come from the upstream advisory (OSV.dev, NVD, FriendsOfPHP); KEV marks CVEs on CISA's Known Exploited Vulnerabilities list; EPSS is FIRST's 30-day exploitation probability. Rows sort exploitation-first: KEV, then EPSS, then CVSS.